Bug 1123876 - reports - values in Input Controls dialog disappear
Summary: reports - values in Input Controls dialog disappear
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: oVirt
Classification: Retired
Component: ovirt-engine-reports
Version: 3.4
Hardware: Unspecified
OS: Unspecified
urgent
high
Target Milestone: ---
: 3.4.3
Assignee: Shirly Radco
QA Contact: Pavel Stehlik
URL:
Whiteboard: infra
Depends On: 1112641
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-28 14:02 UTC by Yaniv Lavi
Modified: 2014-08-11 06:58 UTC (History)
9 users (show)

Fixed In Version: ovirt-3.4.3 ovirt-engine-reports-3.4.3-2.fc19.noarch.rpm
Doc Type: Bug Fix
Doc Text:
Clone Of: 1112641
Environment:
Last Closed: 2014-08-11 06:58:48 UTC
oVirt Team: ---


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 30711 None None None Never
oVirt gerrit 30761 None None None Never

Description Yaniv Lavi 2014-07-28 14:02:45 UTC
+++ This bug was initially created as a clone of Bug #1112641 +++

Description of problem:
any values user fills in "Input Controls" dialog disappear almost immediately

Version-Release number of selected component (if applicable):
ovirt-engine-reports-3.5.0-1.el6

How reproducible:
always

Steps to Reproduce:
1. in reports portal in folders panel on the left, open folder containing reports (for example oVirt Reports/Reports/Executive)
2. open some report, you will be presented with dialog
3. fill value in any input in dialog

Actual results:
your value will get deleted

Expected results:
value should stay in inputbox

Additional info:

--- Additional comment from Yaniv Dary on 2014-06-24 07:41:42 EDT ---

What browser are you using?
Screencaps or video will help with understanding your issue.



Yaniv

--- Additional comment from  on 2014-06-24 08:45:45 EDT ---



--- Additional comment from  on 2014-06-24 08:46:26 EDT ---

i'm using firefox 29

--- Additional comment from  on 2014-06-24 08:55:10 EDT ---

same bug can be also reproduced on google-chrome 35

--- Additional comment from  on 2014-06-26 05:27:45 EDT ---

also, today i found out that in firefox 30 you can't even select these inputs - if you click inside one of them you will not get the blinking cursor in textbox, and you can't type at all, that might be related to this issue, too

--- Additional comment from  on 2014-06-26 09:54:30 EDT ---

i just installed 3.4 and dialog inputs work there, so this is a regression

--- Additional comment from Shirly Radco on 2014-07-01 02:51:22 EDT ---

It seems that maybe you need to update the jar files.

Please run engine-setup again.

This should update the following JAR files 

WebadminLineBarChartTheme.jar
ReportsStatus.jar
ReportsPieChartTheme.jar
ReportsLineBarChartTheme.jar
EngineAuthentication.jar
CustomOvirtReportsQueryManipulator.jar
ChartsCustomizers.jar


located under ./var/lib/ovirt-engine-reports/ovirt-engine-reports.war
Please check if they were indeed updated.

--- Additional comment from Yaniv Dary on 2014-07-07 09:59:27 EDT ---

Were you able to fix this issue?


Yaniv

--- Additional comment from  on 2014-07-14 02:08:41 EDT ---

sorry, after i updated RPMs, i could not successfully run engine-setup because of https://bugzilla.redhat.com/show_bug.cgi?id=1114914

--- Additional comment from Shirly Radco on 2014-07-22 07:26:57 EDT ---

The related bug is fixed.
Please see if you can recreate.

Shirly


Note You need to log in before you can comment on or make changes to this bug.