Bug 1123924 - [Docs][PRD3.5][3.5Beta][Change][Install][Admin][Technical] ethtool_opts functionality supported
Summary: [Docs][PRD3.5][3.5Beta][Change][Install][Admin][Technical] ethtool_opts func...
Keywords:
Status: CLOSED DUPLICATE of bug 1250877
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: Documentation
Version: 3.5.0
Hardware: Unspecified
OS: Unspecified
high
unspecified
Target Milestone: ---
: 3.5.5
Assignee: rhev-docs@redhat.com
QA Contact: Andrew Burden
URL:
Whiteboard: docs
Depends On: 1044033
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-28 16:02 UTC by Julie
Modified: 2016-02-10 18:57 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-09-28 02:22:56 UTC
oVirt Team: Docs


Attachments (Terms of Use)
screenshot (115.79 KB, application/octet-stream)
2014-09-12 05:09 UTC, Laura Novich
no flags Details

Description Julie 2014-07-28 16:02:49 UTC
Feature: 

Ability to configure ethtool options from within RHEV-M.

Reason: 

RHEV-M by default only configures a small subset of the configurable values of a network interface.

However, some users would like to use the ethtool utility to customize their usage of network interface, e.g. to prevent a faulty interface driver from performing hardware offloading.

Result: 

Any ethtool options can now be supplied when provisioning a network on a host via a "custom properties" mechanism, similar to others in RHEV-M, using the key "ethtool_opts" of a network that is to reside on the physical interface.

Note that the engine-config has to be used initially for the "ethtool_opts" key to be made available. If no validation of the supplied ethtool arguments is required, the following command will achieve this:

engine-config -s 'UserDefinedNetworkCustomProperties=ethtool_opts=.*' --cver='3.5'

Moreover, the hook corresponding to this pre-defined custom property - vdsm-hook-ethtool-options - should be installed on the relevant hosts (via yum).

These properties are accessible both via the Setup Host Networks dialog in the webadmin console (when configuring a specific network), and via the Setup Networks action in the RESTful API (and derived SDKs).

Install/ Admin Guide shared topic:
https://access.redhat.com/documentation/en-US/Red_Hat_Enterprise_Virtualization/3.4/html-single/Installation_Guide/index.html#Editing_host_network_interfaces
Technical Guide may require new topic.

PRD: https://bugzilla.redhat.com/show_bug.cgi?id=1044033

Additional Info: http://www.ovirt.org/Features/Network_Custom_Properties#Ethtool_options

SME Contact: Lior (lvernia@redhat.com)

Comment 1 Laura Novich 2014-09-12 05:09:12 UTC
Created attachment 936727 [details]
screenshot

Comment 3 Andrew Dahms 2015-09-03 00:37:52 UTC
Changing status back to 'New' until re-assignment.

Comment 4 Julie 2015-09-28 02:22:56 UTC
Closing this as a duplicate of the newly opened bug as BZ#1250877 has two support cases attached.

*** This bug has been marked as a duplicate of bug 1250877 ***


Note You need to log in before you can comment on or make changes to this bug.