Bug 1123954 - [abrt] evolution: pango_cairo_renderer_show_text_glyphs(): evolution killed by SIGSEGV
Summary: [abrt] evolution: pango_cairo_renderer_show_text_glyphs(): evolution killed b...
Keywords:
Status: CLOSED DUPLICATE of bug 813344
Alias: None
Product: Fedora
Classification: Fedora
Component: evolution
Version: 21
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Matthew Barnes
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:7ea3ab74fe7f28f74c1d1da07e5...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-28 17:51 UTC by Adam Williamson
Modified: 2014-07-29 08:07 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-07-29 08:07:04 UTC


Attachments (Terms of Use)
File: backtrace (169.45 KB, text/plain)
2014-07-28 17:51 UTC, Adam Williamson
no flags Details
File: cgroup (190 bytes, text/plain)
2014-07-28 17:51 UTC, Adam Williamson
no flags Details
File: core_backtrace (87.31 KB, text/plain)
2014-07-28 17:51 UTC, Adam Williamson
no flags Details
File: dso_list (26.21 KB, text/plain)
2014-07-28 17:51 UTC, Adam Williamson
no flags Details
File: environ (1.77 KB, text/plain)
2014-07-28 17:51 UTC, Adam Williamson
no flags Details
File: limits (1.29 KB, text/plain)
2014-07-28 17:51 UTC, Adam Williamson
no flags Details
File: maps (135.17 KB, text/plain)
2014-07-28 17:51 UTC, Adam Williamson
no flags Details
File: open_fds (3.93 KB, text/plain)
2014-07-28 17:51 UTC, Adam Williamson
no flags Details
File: proc_pid_status (959 bytes, text/plain)
2014-07-28 17:51 UTC, Adam Williamson
no flags Details
File: var_log_messages (10.86 KB, text/plain)
2014-07-28 17:51 UTC, Adam Williamson
no flags Details

Description Adam Williamson 2014-07-28 17:51:01 UTC
Description of problem:
Crashed while I was in the middle of composing a rather long email. Grr.

Version-Release number of selected component:
evolution-3.12.4-1.fc21

Additional info:
reporter:       libreport-2.2.3
backtrace_rating: 4
cmdline:        /usr/bin/evolution
crash_function: pango_cairo_renderer_show_text_glyphs
executable:     /usr/bin/evolution
kernel:         3.16.0-0.rc6.git2.2.fc22.x86_64
runlevel:       N 5
type:           CCpp
uid:            1001

Truncated backtrace:
Thread no. 1 (10 frames)
 #0 pango_cairo_renderer_show_text_glyphs at pangocairo-render.c:470
 #1 pango_cairo_renderer_draw_glyphs at pangocairo-render.c:516
 #2 pango_renderer_draw_glyphs at pango-renderer.c:641
 #3 _pango_cairo_do_glyph_string at pangocairo-render.c:928
 #4 pango_cairo_show_glyph_string at pangocairo-render.c:1064
 #5 draw_glyphs at /lib64/libgtkhtml-4.0.so.0
 #6 draw at /lib64/libgtkhtml-4.0.so.0
 #11 html_engine_draw_real at /lib64/libgtkhtml-4.0.so.0
 #12 html_engine_draw_cb at /lib64/libgtkhtml-4.0.so.0
 #13 draw at /lib64/libgtkhtml-4.0.so.0

Potential duplicate: bug 813344

Comment 1 Adam Williamson 2014-07-28 17:51:04 UTC
Created attachment 921866 [details]
File: backtrace

Comment 2 Adam Williamson 2014-07-28 17:51:05 UTC
Created attachment 921867 [details]
File: cgroup

Comment 3 Adam Williamson 2014-07-28 17:51:07 UTC
Created attachment 921868 [details]
File: core_backtrace

Comment 4 Adam Williamson 2014-07-28 17:51:08 UTC
Created attachment 921869 [details]
File: dso_list

Comment 5 Adam Williamson 2014-07-28 17:51:09 UTC
Created attachment 921870 [details]
File: environ

Comment 6 Adam Williamson 2014-07-28 17:51:10 UTC
Created attachment 921871 [details]
File: limits

Comment 7 Adam Williamson 2014-07-28 17:51:11 UTC
Created attachment 921872 [details]
File: maps

Comment 8 Adam Williamson 2014-07-28 17:51:12 UTC
Created attachment 921873 [details]
File: open_fds

Comment 9 Adam Williamson 2014-07-28 17:51:13 UTC
Created attachment 921874 [details]
File: proc_pid_status

Comment 10 Adam Williamson 2014-07-28 17:51:14 UTC
Created attachment 921875 [details]
File: var_log_messages

Comment 11 Milan Crha 2014-07-29 08:07:04 UTC
Thanks for a bug report. I did not see a similar crash for years. The bug 813344, found by abrt, looks pretty much the same, thus I mark this as a duplicate of it. It has a reference to an upstream bugzilla, where the bug is still opened. I'm afraid that the solution will be 3.14 with webkit-based composer, because GtkHTML is quite unmaintained these days.

*** This bug has been marked as a duplicate of bug 813344 ***


Note You need to log in before you can comment on or make changes to this bug.