Bug 112402 - lscpi can't find pci.ids database
Summary: lscpi can't find pci.ids database
Status: CLOSED DUPLICATE of bug 111665
Alias: None
Product: Fedora
Classification: Fedora
Component: pciutils   
(Show other bugs)
Version: 1
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-12-19 00:33 UTC by Bastien Nocera
Modified: 2014-03-17 02:41 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 19:00:28 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Bastien Nocera 2003-12-19 00:33:10 UTC
lspci doesn't seem to be able to find the pci.ids database from hwdata.

$ rpm -q pciutils hwdata
pciutils-2.1.11-3
hwdata-0.101-1
$ lspci
pcilib: Cannot open /sys/bus/pci/devices
0000:00:00.0 Class 0600: 1039:0651 (rev 01)
0000:00:01.0 Class 0604: 1039:0001
<snip>

$ lspci -i /usr/share/hwdata/pci.ids
0000:00:00.0 Host bridge: Silicon Integrated Systems [SiS] SiS651 Host
(rev 01)
0000:00:01.0 PCI bridge: Silicon Integrated Systems [SiS] SiS 530
Virtual PCI-to-PCI bridge (AGP)
<snip>

Comment 1 Kaj J. Niemi 2003-12-19 01:09:04 UTC
The problem with wrong path to pci.ids got fixed in pciutils-2.1.11-4
(bug #111665).

Are you running kernel 2.6? You need to mount /sys first but it looks
like it's falling back to using /proc.



Comment 2 Bill Nottingham 2003-12-19 03:57:18 UTC

*** This bug has been marked as a duplicate of 111665 ***

Comment 3 Red Hat Bugzilla 2006-02-21 19:00:28 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.