Bug 1124207 - [self-hosted-engine] Adjust engine management network settings when deployed over VLAN
Summary: [self-hosted-engine] Adjust engine management network settings when deployed ...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: oVirt
Classification: Retired
Component: ovirt-hosted-engine-setup
Version: 3.5
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: 3.5.0
Assignee: Antoni Segura Puimedon
QA Contact: Michael Burman
URL:
Whiteboard: integration
: 1124206 (view as bug list)
Depends On: 1139020 1147254
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-29 06:49 UTC by Martin Pavlik
Modified: 2014-12-08 00:53 UTC (History)
15 users (show)

Fixed In Version: ovirt-3.5.0_rc2
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-10-17 12:34:06 UTC
oVirt Team: ---


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 32269 master MERGED Update engine's mgmt net to have the correct vlan id Never
oVirt gerrit 32374 ovirt-hosted-engine-setup-1.2 MERGED Update engine's mgmt net to have the correct vlan id Never
Red Hat Bugzilla 1076944 None None None Never

Internal Links: 1076944

Description Martin Pavlik 2014-07-29 06:49:33 UTC
Description of problem:
When self hosted engine is being deployed over VLAN it leads to situation when physical host is being made non-operational in the engine because hosts network is out of sync from cluster settings.

It is caused by engine-setup deploying engine with management network which does not have VLAN tag by default.

Self hosted engine should take care of this in the final configuration stage (after user confirms that engine is installed)

Version-Release number of selected component (if applicable):
3.5

How reproducible:
100%

Steps to Reproduce:
1. configure VLAN tagged interface on physical host
2. yum install ovirt-hosted-engine-setup
3. ovirt-hosted-engine-setup --deploy
4. choose the VLAN interface to be used for deployment
5. finish the deployment

Actual results:
physical host is non-operational in self hosted engine GUI

Expected results:
physical host is UP (ovirt-hosted-engine-setup --deploy takes care of configuring management network as VLAN tagged)

Additional info:
at the moment host can be made operational by manual adjustment of management network in self hosted engine, however it must be VERY inconvenient for new users 

this would be worth documenting in Installation_Guide/Installing_the_Self-Hosted_Engine.html

Comment 1 Sandro Bonazzola 2014-08-08 13:41:36 UTC
*** Bug 1124206 has been marked as a duplicate of this bug. ***

Comment 2 Sandro Bonazzola 2014-08-08 13:43:46 UTC
Antoni, is this case covered by your patch at http://gerrit.ovirt.org/28595 ?

Comment 3 Antoni Segura Puimedon 2014-08-08 13:51:44 UTC
@Sandro,

My patch improves the configuration of the vdsm side. IIUC Martin talks about the problem that the engine representation of the ovirtmgmt network is not configured as vlanned, thus leading to the out-of-sync issue.

This should either be solved by configuring the engine ovirtmgmt network to be vlanned when configuring the hosted engine over a vlan or, perhaps in the future, not caring for more than connectivity for the management network (in terms of syncing).

Comment 4 Michael Burman 2014-10-14 06:07:32 UTC
Verified on -3.5.0-0.14.beta.el6ev and ovirt-hosted-engine-setup-1.2.1-1.el6ev.noarch

Comment 5 Sandro Bonazzola 2014-10-17 12:34:06 UTC
oVirt 3.5 has been released and should include the fix for this issue.


Note You need to log in before you can comment on or make changes to this bug.