Bug 1124366 - L10N: config file is not applied automatically.
Summary: L10N: config file is not applied automatically.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: man-db
Version: 20
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Jan Chaloupka
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1126120 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-29 10:59 UTC by Takayuki Ogawa
Modified: 2014-08-08 08:39 UTC (History)
3 users (show)

Fixed In Version: man-db-2.6.5-4.fc20
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-08 08:39:04 UTC


Attachments (Terms of Use)
Actual results: the text layout is not good. (157.40 KB, image/png)
2014-07-29 10:59 UTC, Takayuki Ogawa
no flags Details
Expected result (189.48 KB, image/png)
2014-07-29 11:00 UTC, Takayuki Ogawa
no flags Details

Description Takayuki Ogawa 2014-07-29 10:59:55 UTC
Created attachment 922105 [details]
Actual results: the text layout is not good.

Description of problem:
Japanese man pages do not insert newline code between Japanese sentence.
Because Japanese and Chinese sentense do not divide words by space,
groff seems to avoid breaking line.

I looked in /usr/share/groff/current/tmac/ directory and I found several L10N files such as ja.tmac, fr.tmac and de.tmac.
In ja.tmac, Japanese character class is specified correctly, but this file seems not to be enabled.

Do I have to load these files manually to localize man page?

Version-Release number of selected component (if applicable):
groff-base-1.22.2-8.fc20.x86_64
man-db-2.6.5-2.fc20.x86_64

Actual results:
see attached image file.

Expected results:
I added the following line to andoc.tmac file and captured the image as attached file.
*** andoc.tmac.bak	2013-10-02 03:00:22.000000000 +0900
--- andoc.tmac	2014-07-29 19:53:18.841625623 +0900
***************
*** 27,32 ****
--- 27,34 ----
  .if !\n(.g \
  .  ab These macros require groff.
  .
+ .do mso ja.tmac
+ .
  .nr _C \n(.C
  .cp 0
  .



Additional info:

Comment 1 Takayuki Ogawa 2014-07-29 11:00:56 UTC
Created attachment 922106 [details]
Expected result

Comment 2 Akira TAGOH 2014-08-04 06:37:31 UTC
*** Bug 1126120 has been marked as a duplicate of this bug. ***

Comment 3 Jan Chaloupka 2014-08-04 07:14:28 UTC
Hi, Takayuki,

setting the following:

$ export LANG=ja
$ export LC_ALL=ja_JP.UTF8

I see expected result. What is you setting of these variables?

$ export | grep LANG
$ export | grep LC_ALL

will show their values.

I get your actual result by displaying man man and then re-sizing the page to smaller width.

Regards
Jan

Comment 4 Takayuki Ogawa 2014-08-04 07:29:33 UTC
Hello, Jan.
Thanks for the reply.

> I see expected result. What is you setting of these variables?
>
> $ export | grep LANG
> $ export | grep LC_ALL
>
> will show their values.

The result of them are as below. LC_ALL is not defined in my environment.

[takayuki@localhost ~]$ export | grep LANG
declare -x LANG="ja_JP.UTF-8"
[takayuki@localhost ~]$ export | grep LC_ALL
[takayuki@localhost ~]$ 

Regards.

Comment 5 Jan Chaloupka 2014-08-04 07:59:01 UTC
Now I can see. Thank you.

Comment 8 Fedora Update System 2014-08-04 08:56:52 UTC
man-db-2.6.5-4.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/man-db-2.6.5-4.fc20

Comment 9 Fedora Update System 2014-08-07 15:25:22 UTC
Package man-db-2.6.5-4.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing man-db-2.6.5-4.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-9165/man-db-2.6.5-4.fc20
then log in and leave karma (feedback).

Comment 10 Takayuki Ogawa 2014-08-07 22:34:24 UTC
man-db-2.6.5-4.fc20 works for me.
I added comment to
https://admin.fedoraproject.org/updates/FEDORA-2014-9165/man-db-2.6.5-4.fc20
, too.
Thank you.

Comment 11 Jan Chaloupka 2014-08-08 06:16:13 UTC
Takayuki,

thank you for your comment.

Regards
Jan

Comment 12 Fedora Update System 2014-08-08 08:39:04 UTC
man-db-2.6.5-4.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.