Bug 1126120 - Japanese sentence no not wrap correctly.
Summary: Japanese sentence no not wrap correctly.
Keywords:
Status: CLOSED DUPLICATE of bug 1124366
Alias: None
Product: Fedora
Classification: Fedora
Component: man-pages-ja
Version: 20
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Akira TAGOH
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-02 02:10 UTC by Takayuki Ogawa
Modified: 2014-08-04 06:37 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-04 06:37:31 UTC


Attachments (Terms of Use)

Description Takayuki Ogawa 2014-08-02 02:10:02 UTC
Description of problem:
Because Japanese sentence is processed as if it is western one word,
line break is not inserted in the sequence of Japasese chatercters.

Version-Release number of selected component (if applicable):
man-pages-ja-20130815-1.fc20.noarch
man-pages-3.53-3.fc20.noarch
groff-base-1.22.2-8.fc20.x86_64

How reproducible:
Everytime.

Steps to Reproduce:

1. yum install man-pages-ja
2. LANG="ja_JP.UTF-8" man man
3.

Actual results:
Layout of output manual is corrupted.

Expected results:
Japanese sentense line may break in sequence
to typesetting Japanese text correctly.

Additional info:
/usr/share/groff/current/tmac/ja.tmac
defines this rule.

man command works correctly when I append
".do mso ja.tmac" description to
/usr/share/groff/current/tmac/andoc.tmac

I reported this bug 
https://bugzilla.redhat.com/show_bug.cgi?id=1124366
, too.

Comment 1 Akira TAGOH 2014-08-04 06:37:31 UTC
there are no way to do anything for that in man-pages-ja. as you are aware it's a groff issue.

*** This bug has been marked as a duplicate of bug 1124366 ***


Note You need to log in before you can comment on or make changes to this bug.