Bug 1124369 - vdsm to require latest ioprocess
Summary: vdsm to require latest ioprocess
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: oVirt
Classification: Retired
Component: vdsm
Version: 3.5
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 3.5.0
Assignee: Yeela Kaplan
QA Contact: Jiri Belka
URL:
Whiteboard: infra
: 1124764 (view as bug list)
Depends On: 1114908
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-29 11:07 UTC by Federico Simoncelli
Modified: 2016-02-10 19:32 UTC (History)
15 users (show)

Fixed In Version: ioprocess-0.10.0-1.el6_5.noarch, vdsm-v4.16.4
Doc Type: Bug Fix
Doc Text:
Clone Of: 1114908
Environment:
Last Closed: 2014-10-17 12:37:42 UTC
oVirt Team: Infra


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 32136 master MERGED spec: require latest ioprocess version Never
oVirt gerrit 32247 ovirt-3.5 ABANDONED spec: require latest ioprocess version Never
oVirt gerrit 32569 master MERGED spec: Require latest ioprocess Never
oVirt gerrit 32571 ovirt-3.5 MERGED spec: Require latest ioprocess Never

Description Federico Simoncelli 2014-07-29 11:07:26 UTC
Bug cloned to address the relevant "requires" in vdsm.spec

+++ This bug was initially created as a clone of Bug #1114908 +++

Description of problem:
By default the newly introduced ioprocess package is excessively verbose in logging.

Version-Release number of selected component (if applicable):
vdsm-4.16.0-6.git5d3ed2d.el6.x86_64
python-ioprocess-0.5.0-2.el6_5.noarch

How reproducible:
100%

Steps to Reproduce:
1. create storage domain
2. add storage domain
3. create disks

Actual results:
Excessive logging in vdsm.log

--- Additional comment from Barak on 2014-07-28 07:31:25 EDT ---

I would still say it misses an appropriate "requires:" patch in the vdsm spec file.

Comment 1 Michal Skrivanek 2014-07-30 10:43:17 UTC
*** Bug 1124764 has been marked as a duplicate of this bug. ***

Comment 2 Michal Skrivanek 2014-07-30 10:43:27 UTC
from th original bug: Nir Soffer 2014-07-30 11:23:30 CEST

Expected logs when using jsonrpc:

- One debug log per connection
- One debug log for protocol detection
- One debug log when starting a request
- One debug log when finishing a request
- Errors and warnings

Comment 3 Jiri Belka 2014-09-22 09:56:44 UTC
ok, i don't see any 'DEBUG|' stuff in vdsm.log like described in https://bugzilla.redhat.com/show_bug.cgi?id=1114908#c0

vdsm-4.16.4-0.el6.x86_64
ioprocess-0.12.0-2.el6.x86_64

Comment 4 Sandro Bonazzola 2014-10-17 12:37:42 UTC
oVirt 3.5 has been released and should include the fix for this issue.


Note You need to log in before you can comment on or make changes to this bug.