Bug 1124764 - extreme amount of irrelevant jsonrpc related log in vdsm log
Summary: extreme amount of irrelevant jsonrpc related log in vdsm log
Keywords:
Status: CLOSED DUPLICATE of bug 1124369
Alias: None
Product: oVirt
Classification: Retired
Component: vdsm
Version: 3.5
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: ---
Assignee: Dan Kenigsberg
QA Contact: Gil Klein
URL:
Whiteboard: infra
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-30 09:20 UTC by Nir Soffer
Modified: 2014-07-30 10:43 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-07-30 10:43:17 UTC
oVirt Team: ---


Attachments (Terms of Use)
Output of "grep jsonrpc vdsm.log" (540.18 KB, text/x-log)
2014-07-30 09:20 UTC, Nir Soffer
no flags Details

Description Nir Soffer 2014-07-30 09:20:24 UTC
Created attachment 922472 [details]
Output of "grep jsonrpc vdsm.log"

Description of problem:

Looking in vdsm logs, we have too much noise related to how jsonrpc
server is implemented. These logs should be eliminated - the operation
of the server must be verified using unit tests, not by looking at the
logs.

See jsonrpc.log for json rpc related messages - most of them are have
no value for debugging application related issues.

Version-Release number of selected component (if applicable):
vdsm 4.16.1-0.gita4d9abf.fc19

Comment 1 Nir Soffer 2014-07-30 09:23:30 UTC
Expected logs when using jsonrpc:

- One debug log per connection
- One debug log for protocol detection
- One debug log when starting a request
- One debug log when finishing a request
- Errors and warnings

Comment 2 Michal Skrivanek 2014-07-30 10:43:17 UTC

*** This bug has been marked as a duplicate of bug 1124369 ***


Note You need to log in before you can comment on or make changes to this bug.