Bug 1124383 - [Setup] - when clean install fails after war is deployed it remains in the file system and not deleted
Summary: [Setup] - when clean install fails after war is deployed it remains in the fi...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-reports
Version: 3.4.0
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
: 3.4.2
Assignee: Shirly Radco
QA Contact: movciari
URL:
Whiteboard: integration
Depends On: 1072357 1112305
Blocks: 1123858
TreeView+ depends on / blocked
 
Reported: 2014-07-29 11:39 UTC by Petr Matyáš
Modified: 2014-09-04 12:47 UTC (History)
14 users (show)

Fixed In Version: av11 - rhevm-reports-3.4.2-1.el6ev
Doc Type: Bug Fix
Doc Text:
'war' file is now deleted from the file system after a clean install of reports fails in engine setup.
Clone Of: 1112305
Environment:
Last Closed: 2014-09-04 12:47:59 UTC
oVirt Team: ---


Attachments (Terms of Use)
logs (415.70 KB, application/gzip)
2014-08-13 13:37 UTC, movciari
no flags Details
part of output of rhevm-setup with error (937 bytes, text/plain)
2014-08-13 13:38 UTC, movciari
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:1151 normal SHIPPED_LIVE rhevm-reports 3.4.2 bug fix update 2014-09-04 16:47:21 UTC
oVirt gerrit 28653 None None None Never
oVirt gerrit 29071 None None None Never
oVirt gerrit 30968 ovirt-engine-reports-3.4 ABANDONED reports: remove war file for new db Never
oVirt gerrit 31003 ovirt-engine-reports-3.4 MERGED reports: remove war file for new db Never

Description Petr Matyáš 2014-07-29 11:39:53 UTC
+++ This bug was initially created as a clone of Bug #1112305 +++
Verified by mistake, when I noticed it, it was released pending. Bug is still there.

+++ This bug was initially created as a clone of Bug #1072357 +++

Description of problem:
when clean install fails after war is deployed it remains in the file system and not deleted.

Version-Release number of selected component (if applicable):
3.4.0

How reproducible:
Always

Steps to Reproduce:
1. run engine-setup with reports plugin
2. fail install after war is deployed.

Actual results:
War remain in file system

Expected results:
War should be clean to return system to the previous state 

Additional info:

--- Additional comment from Yaniv Dary on 2014-06-23 08:47:14 EDT ---

Please manually cherry pick to 3.4 branch there is a merge conflict.



Yaniv

--- Additional comment from errata-xmlrpc on 2014-06-23 08:51:00 EDT ---

Bug report changed to ON_QA status by Errata System.
A QE request has been submitted for advisory RHEA-2014:18129-02
https://errata.devel.redhat.com/advisory/18129

--- Additional comment from errata-xmlrpc on 2014-06-23 09:25:04 EDT ---

This bug has been dropped from advisory RHEA-2014:18129 by Shirly Radco (sradco@redhat.com)

--- Additional comment from errata-xmlrpc on 2014-06-24 14:00:21 CEST ---

Bug report changed to ON_QA status by Errata System.
A QE request has been submitted for advisory RHBA-2014:18157-01
https://errata.devel.redhat.com/advisory/18157

--- Additional comment from errata-xmlrpc on 2014-07-29 04:00:39 CEST ---

Bug report changed to RELEASE_PENDING status by Errata System.
Advisory RHBA-2014:18157-04 has been changed to PUSH_READY status.
https://errata.devel.redhat.com/advisory/18157

Comment 1 movciari 2014-07-29 13:54:06 UTC
now this bug is exactly same as bz1072357
you should probably change target release to 3.4.z or close this one as duplicate

Comment 3 movciari 2014-08-08 12:26:37 UTC
tested on av11, still doesn't remove war (i cancelled installation with ctrl+c during  Customizing Jasper Pro Parts stage)

Comment 4 Shirly Radco 2014-08-10 11:38:47 UTC
Hi,

I just retested miself the av11 and it works ok.
The file that should be deleted is ovirt-engine-reports.war along with modules,
build-conf directories.
They are deployed to /var/lib/ovirt-engine-reports/ during "Deploying Jasper" step. 
After cancelling they are removed from there. 
Do you have a vm I can where I can see the problem you are having?
What version are you using?

Shirly

Comment 5 movciari 2014-08-11 08:55:13 UTC
yes, /var/lib/ovirt-engine-reports/ovirt-engine-reports.war is still present in the system after cancelling installation during "Customizing Jasper Pro Parts" stage
i tested it on av11 as i said (rhevm-reports-setup-3.4.2-1.el6ev.noarch), maybe the problem occurs only when it fails in certain stages of setup, if you want access to machine where i reproduced this, ask me on irc

Comment 6 Shirly Radco 2014-08-12 13:04:20 UTC
Michal,

Please update results of installation on a clean vm.

Shirly

Comment 7 movciari 2014-08-13 12:08:59 UTC
same results on a clean vm

Comment 8 movciari 2014-08-13 13:37:50 UTC
Created attachment 926441 [details]
logs

Comment 9 movciari 2014-08-13 13:38:42 UTC
Created attachment 926442 [details]
part of output of rhevm-setup with error

Comment 10 movciari 2014-08-14 13:34:55 UTC
ok, problem was the incorrect version of otopi - i had otopi-1.3.0-0.0.master.20140728.git336a22e.el6.noarch (maybe rhevm-setup should have correct version as a dependency)
i can't reproduce with correct version of otopi so this can be verified

Comment 12 errata-xmlrpc 2014-09-04 12:47:59 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1151.html


Note You need to log in before you can comment on or make changes to this bug.