Bug 112455 - Sony VAIO laptop fails to load ide1 driver when PCMCIA card inserted
Sony VAIO laptop fails to load ide1 driver when PCMCIA card inserted
Product: Fedora
Classification: Fedora
Component: pcmcia-cs (Show other bugs)
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Pete Zaitcev
Brian Brock
: 119659 (view as bug list)
Depends On:
  Show dependency treegraph
Reported: 2003-12-19 18:09 EST by Bevis King
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-04-28 09:33:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Bevis King 2003-12-19 18:09:07 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1)
Gecko/20031114 Galeon/1.3.10

Description of problem:
When I insert the PCMCIA interface card of the Sony PCGA-CD51/A CD-ROM
drive into my Sony VAIO laptop (PCG-Z600LEK), the cs driver fails to
load the appropriate ide driver with the message:

cs: memory probe 0xa0000000-0xa0ffffff: clean.
ide-cs: GetNextTuple: No more items

The CD-ROM drive usually appears as hde on previous Linux kernels. 
Current kernel is 2.4.22-1.2115.nptl.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.  Insert CD-ROM PCMCIA interface card into slot
2.  Check dmesg


Actual Results:  Error message: ide-cs: GetNextTuple: No more items

Drive not visible.

Expected Results:  Driver loads, CD-ROM becomes either /dev/hdc or
/dev/hde and becomes usable.

Additional info:

Worked on RedHat Linux 9.
Comment 2 wim philipsen 2004-11-21 10:54:00 EST
save thing still happens at with core 3, on a sony pcg-n505vx, cd51 cdrom.

used to work on all previous RedHat verseions. Sometimes had to tinker
with the interrupts in pcmcia.config
Comment 3 Dave Jones 2005-02-24 00:49:37 EST
if you edit /etc/pcmcia/config.opts and remove the lines for the Radeon IGP
workaround, does it work ?
Comment 4 Dave Jones 2005-02-24 00:50:44 EST
*** Bug 119659 has been marked as a duplicate of this bug. ***
Comment 5 Mike Schoen 2005-04-27 13:35:37 EDT
fwiw I just tried this on a sony vaio z505ls with the cd51 drive and commenting
out the line suggested by Dave Jones worked.  The cd drive mounted as /dev/hde.
Comment 6 John Thacker 2006-04-28 09:33:12 EDT
No response from reporter to request for a year.
FC3 is the responsibility of Fedora Legacy, and this is not a security issue.
If it can be reproduced on FC4 or FC5, please reopen.
Note that pcmcia-cs has been replaced by pcmciautils in FC5.

Note You need to log in before you can comment on or make changes to this bug.