Bug 119659 - (VAIO IDE)Installer can't find pcmcia cdrom
(VAIO IDE)Installer can't find pcmcia cdrom
Status: CLOSED DUPLICATE of bug 112455
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
Depends On:
Blocks: FC2Target FC3Target FC4Target
  Show dependency treegraph
Reported: 2004-04-01 01:06 EST by Akkana
Modified: 2015-01-04 17:05 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2005-02-24 00:50:37 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Akkana 2004-04-01 01:06:56 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7a)

Description of problem:
I'm trying to install on a Sony Vaio SR17.
This machine uses an external pcmcia cdrom drive.
It was well supported by Redhat 7.x and 8.0 installers (and debian and
xandros), but the fedora test2 installer can't find the cdrom, and
prompts me with a list of drivers.  None of these drivers seem to
involve pcmcia/cardbus, except for one pcmcia scsi driver (Qlogic).

More specific info about the hardware on request, but I'm guessing
this is a case of pcmcia not being there.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Insert CD into drive.
2. Plug drive into pcmcia slot.
3. Power machine on, hit return on all the defaults making sure to
choose a cdrom install.

Actual Results:  "Unable to find any devices of the type needed for
this installation type.  Would you like to manually select your driver
or use a driver disk?"

Expected Results:  CD found, makes clunking and whirring noises,
install proceeds.

Additional info:

ctl-alt-f5 showed me a screen that reported, among other things,
<6> Yenta: CardBus bridge found at 0000:00:0c.0 [104d:8094]
<6> Yenta: ISA IRQ mask 0x0cb8, PCI irq 9

But I don't see anything mentioning the cdrom.  So maybe pcmcia/yenta
is loaded, and it's some other module, like ide-cs, that's missing?

With some older distro installers (including redhat 9) this particular
machine and cdrom required the boot time parameter: ide2=0x180,0x386
So I tried that (also ide1=, which worked on a lot of other distro's
installers in the past) but that hung the fedora installer: after
loading the usb and firewire drivers, it accesses the cdrom, I hear a
couple of noises from the drive, and the screen freezes, all blue
except for the single line legend at the bottom (about <Tab> and so
Comment 1 Jeremy Katz 2004-04-05 17:38:58 EDT
It sounds like the ide2= is needed, but then the kernel hangs.  Are
your keyboard leds flashing at that point?
Comment 2 Akkana 2004-04-06 01:13:59 EDT
No LEDs flashing.

The ide2= parameter doesn't seem to be needed for booting into linux
in kernels after 2.4.25, or current 2.6 kernels (after 2.6.3, I think,
not sure about earlier).  What kernel does FC2test2 use?

When the install hangs, ctl-alt-F3 works, and gets me to a screen
where the last message is (not surprisingly):
* trying to mount CD device hde

ctl-alt-F4 ends with:
<3>hde: drive not ready for command
<4>hde: ATAPI reset timed-out, status=0xff
<4>ide2: reset timed-out, status=0xff
<4>end_request: I/O error, dev hde, sector 64
<4>isofs_fill_super: bread failed, dev=hde, iso_blknum=16, block=16

(prior to that are lots of repetitions of similar errors).
Comment 3 Alan Cox 2004-05-03 10:54:54 EDT
You need pci=off ide=0x180,0x386

(And not test3 where pci=off is broken [sorry]).

The Sony maps the PCMCIA CD-ROM as a legacy IDE device so you can
update even old OS's and install via their CD-ROM. This is neat but
when Fedora loads the cardbus driver the CD-ROM vanishes as the
cardbus is configured and there isn't yet a hotplug capable cardbus
ide driver in Linux.

Comment 4 Akkana 2004-11-19 14:19:39 EST
Update based on the FC3 release, tested on an SR33 (similar to the
SR17 in its PCMCIA CD handling):

It looks like pci=off is still broken even in the released FC3.  It
generates a kernel panic, either with the line Alan gives above, or
with the different line (ide1=, not ide=) given in the FC3 release notes.

Booting with ide2=0x180,0x386 does see the CD.  (Though the FC3
install does not complete; "The installer exited abnormally" after the
first CD, and rebooting seems to show a correctly installed cmdline
fedora with none of the X or other software that should have been
installed.)  Didn't try ide1=, but it has also worked in the past.

Booting with ide=0x180,0x386 (no pci=) fails; it doesn't kernel panic,
just says "No CD found".  So ide1= or ide2= is apparently needed, not
just ide=.
Comment 5 Dave Jones 2005-02-24 00:50:37 EST

*** This bug has been marked as a duplicate of 112455 ***

Note You need to log in before you can comment on or make changes to this bug.