Bug 1124560 - yum upgrade fails
Summary: yum upgrade fails
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: filesystem
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Ondrej Vasik
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1124908 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-29 19:30 UTC by Lokesh Mandvekar
Modified: 2014-07-31 08:33 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-07-30 12:47:10 UTC


Attachments (Terms of Use)

Description Lokesh Mandvekar 2014-07-29 19:30:22 UTC
Description of problem:
yum update gives me this: 

Is this ok [y/d/N]: y
Downloading packages:
Running transaction check
Running transaction test
Transaction test succeeded
Running transaction (shutdown inhibited)
Transaction couldn't start:
file /media from install of filesystem-3.2-28.fc22.x86_64 conflicts with file from package filesystem-3.2-27.fc22.x86_64


[('file /media from install of filesystem-3.2-28.fc22.x86_64 conflicts with file from package filesystem-3.2-27.fc22.x86_64', (7, '/media', 897L))]


Version-Release number of selected component (if applicable):
filesystem-3.2-28.fc22.x86_64

How reproducible:
consistent


Steps to Reproduce:
1. yum update

Comment 1 Lokesh Mandvekar 2014-07-29 19:52:13 UTC
On a VPS of mine, I was stupid enough to remove the filesystem package in the hopes of installing the newer version later, and at this point everything simply blew up :\ (mainly all possible shell commands apart from cd were unavailable) ... perhaps this should be a core/critical package (???)

Comment 2 Lokesh Mandvekar 2014-07-30 03:26:37 UTC
So on my local machine, I mv'd /media to /media.safe and then yum update ran totally fine. After the update I noticed the symlink /media -> /run/media but after a reboot /run/media was no longer there, at which point I deleted the symlink and mv'd /media.safe back to /media. Probably a crappy hack but all seems well now.

Comment 3 Ondrej Vasik 2014-07-30 12:47:10 UTC
Thanks for report and sorry for broken -28.fc22. Renaming the directory is recommended by the packaging guidelines ( https://fedoraproject.org/wiki/Packaging:Directory_Replacement ) and was done in -29.fc22 . Closing RAWHIDE.

Comment 4 Lokesh Mandvekar 2014-07-30 14:15:51 UTC
Thanks Ondrej!

Comment 5 Ondrej Vasik 2014-07-31 08:33:09 UTC
*** Bug 1124908 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.