Bug 112457 - rhn_register abends if hostname is not resolvable
rhn_register abends if hostname is not resolvable
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 2.1
Classification: Red Hat
Component: up2date (Show other bugs)
2.1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Adrian Likins
Fanny Augustin
:
: 112458 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-12-19 18:56 EST by Omkhar Arasaratnam
Modified: 2007-11-30 17:06 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-24 17:49:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Omkhar Arasaratnam 2003-12-19 18:56:19 EST
Description of problem:

If up2date is not able to resolve the hostname of the system it will
abend with a python exception when it tries to grab the system info

Version-Release number of selected component (if applicable):
2.9.3-2.2.1AS

How reproducible:
make hostname not resolveable, (remove from /etc/hosts or DNS servers)
and run rhn_register

Steps to Reproduce:
1.
2.
3.
  
Actual results:
abend (python trace back)

Expected results:
register machine

Additional info:
Comment 1 Adrian Likins 2004-08-24 17:50:05 EDT
*** Bug 112458 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.