Bug 1124692 - If snapshot is attempted when geo-replication session is live, error must be signalled.
Summary: If snapshot is attempted when geo-replication session is live, error must be ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: snapshot
Version: rhgs-3.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: RHGS 3.0.0
Assignee: Sachin Pandit
QA Contact: shilpa
URL:
Whiteboard:
Depends On:
Blocks: 1129038 1145091
TreeView+ depends on / blocked
 
Reported: 2014-07-30 06:02 UTC by Nagaprasad Sathyanarayana
Modified: 2016-09-17 13:02 UTC (History)
11 users (show)

Fixed In Version: glusterfs-3.6.0.28-1
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1129038 (view as bug list)
Environment:
Last Closed: 2014-09-22 19:45:08 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2014:1278 normal SHIPPED_LIVE Red Hat Storage Server 3.0 bug fix and enhancement update 2014-09-22 23:26:55 UTC

Description Nagaprasad Sathyanarayana 2014-07-30 06:02:53 UTC
Description of problem:
This is a product management ask. When geo-replication session is live and snapshot is attempted, error must be signaled. 

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 2 Sachin Pandit 2014-08-18 07:31:19 UTC
A patch which fixes this issue is posted upstream ( http://review.gluster.org/#/c/8461/ ). I'll send a relevant patch downstream once the upstream patch gets merged.

Comment 3 Sachin Pandit 2014-08-20 11:25:46 UTC
http://review.gluster.org/#/c/8461/  is dependent on http://review.gluster.org/#/c/8459/ . Waiting for 8459 to get merged.

Comment 4 Sachin Pandit 2014-08-22 07:23:35 UTC
Patches mentioned below fixes the bug.
https://code.engineering.redhat.com/gerrit/#/c/31281/
https://code.engineering.redhat.com/gerrit/#/c/31282/

Comment 5 ssamanta 2014-08-27 05:19:30 UTC
After discussion with Engineering Leads and PM approving to include it in Denali.

Comment 6 Vijaikumar Mallikarjuna 2014-09-16 06:21:25 UTC
I tested below cases with glusterfs version '3.6.0.28' and snapshot commands works as expected:

Case-1:
a) Created a volume 'master' and created geo-rep session for this volume
b) Tried creating snapshot for volume 'master' when geo-rep in different state and snapshot command failed with proper error message.
    Initializing
    Running

c) Paused geo-rep session and was able to create a snapshot successfully.
d) Stopped geo-rep session and was able to create a snapshot successfully.
e) Resumed geo-rep session and snapshot command failed with proper error message.


Case-2:
a) When geo-rep session is running for a volume 'master', I created a new volume 'master_2'
b) Created a snapshot for new volume 'master_2' and was successful


Case-3:
a) Created geo-rep session multiple slaves
b) Created a snapshot and was successful

Case-4:
a) Created a snapshot on slave machine when geo-rep session is active on master and was successful


Case-5:
a) Stopped a geo-rep session and restarted glusterd
b) Created a snapshot successfully

Case-6:
a) Paused a geo-rep session and restarted glusterd
b) Created a snapshot successfully

Case-7:
a) Started a geo-rep session and restarted glusterd
b) Tried creating snapshot and it failed with proper error message.

Comment 7 M S Vishwanath Bhat 2014-09-16 09:09:41 UTC
The description in the comment 6 looks good.

@aravinda, @naga, @Avra - Just to confirm, the snapshot can be taken at slave at any point of time right? taking snaps in master vol throws error. Right?

Will move the bug to verified based on the information provided by Vijaikumar.

Comment 8 shilpa 2014-09-17 09:15:02 UTC
As per comment #6 this bug is Verified.

Comment 10 errata-xmlrpc 2014-09-22 19:45:08 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2014-1278.html


Note You need to log in before you can comment on or make changes to this bug.