Bug 1129038 - If snapshot is attempted when geo-replication session is live, error must be signaled.
Summary: If snapshot is attempted when geo-replication session is live, error must be ...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: glusterd
Version: mainline
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
Assignee: Sachin Pandit
QA Contact:
URL:
Whiteboard:
Depends On: 1124692
Blocks: 1145091
TreeView+ depends on / blocked
 
Reported: 2014-08-12 07:18 UTC by Sachin Pandit
Modified: 2015-05-14 17:43 UTC (History)
5 users (show)

Fixed In Version: glusterfs-3.7.0
Doc Type: Bug Fix
Doc Text:
Clone Of: 1124692
: 1145091 (view as bug list)
Environment:
Last Closed: 2015-05-14 17:27:06 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Comment 1 Anand Avati 2014-08-12 07:41:13 UTC
REVIEW: http://review.gluster.org/8461 (glusterd/snapshot : Fail the snapshot create operation if geo-rep is running.) posted (#1) for review on master by Sachin Pandit (spandit@redhat.com)

Comment 2 Anand Avati 2014-08-21 17:52:40 UTC
REVIEW: http://review.gluster.org/8461 (glusterd/snapshot : Fail the snapshot create operation if geo-rep is running.) posted (#2) for review on master by Sachin Pandit (spandit@redhat.com)

Comment 3 Anand Avati 2014-08-22 06:57:15 UTC
COMMIT: http://review.gluster.org/8461 committed in master by Krishnan Parthasarathi (kparthas@redhat.com) 
------
commit aa9b19e4b3329f446f0eb9b3a4ed0dbb9ebe4d09
Author: Sachin Pandit <spandit@redhat.com>
Date:   Tue Aug 12 04:14:21 2014 +0530

    glusterd/snapshot : Fail the snapshot create operation if geo-rep is running.
    
    As one of the recommandations for taking a snapshot is not to have
    an active geo-replication session, its better to display an error
    saying session is active when snapshot create command is issued.
    
    Change-Id: I94593dbd2659610e033ca316176dda1ac8dc5ce6
    BUG: 1129038
    Signed-off-by: Sachin Pandit <spandit@redhat.com>
    Reviewed-on: http://review.gluster.org/8461
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Rajesh Joseph <rjoseph@redhat.com>
    Reviewed-by: Atin Mukherjee <amukherj@redhat.com>
    Reviewed-by: Vijaikumar Mallikarjuna <vmallika@redhat.com>
    Reviewed-by: Krishnan Parthasarathi <kparthas@redhat.com>
    Tested-by: Krishnan Parthasarathi <kparthas@redhat.com>

Comment 4 Niels de Vos 2015-05-14 17:27:06 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Comment 5 Niels de Vos 2015-05-14 17:35:32 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Comment 6 Niels de Vos 2015-05-14 17:37:54 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Comment 7 Niels de Vos 2015-05-14 17:43:05 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.