Bug 1124887 - [oVirt][Foreman] Improve error messages when action fails on foreman server
Summary: [oVirt][Foreman] Improve error messages when action fails on foreman server
Keywords:
Status: CLOSED DUPLICATE of bug 1113000
Alias: None
Product: oVirt
Classification: Retired
Component: ovirt-engine-core
Version: 3.5
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 3.5.0
Assignee: Yaniv Bronhaim
QA Contact: Pavel Stehlik
URL:
Whiteboard: infra
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-30 14:47 UTC by Moti Asayag
Modified: 2016-02-10 19:35 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-12 08:12:20 UTC
oVirt Team: Infra


Attachments (Terms of Use)

Description Moti Asayag 2014-07-30 14:47:45 UTC
Description of problem:
Currently, for ant failure on foreman server, there is a generic error message which doesn't reveal the nature of the problem.

Version-Release number of selected component (if applicable):
commit 

How reproducible:
always

Steps to Reproduce:
1. Provision a host via foreman and set a password shorter than 8 characters

Actual results:
Failure message: "Error while executing action New Host: Failed to communicate with the external provider."

Expected results:
A better message.

Additional info:

Comment 1 Oved Ourfali 2014-08-12 08:12:20 UTC

*** This bug has been marked as a duplicate of bug 1113000 ***


Note You need to log in before you can comment on or make changes to this bug.