Bug 1125141 - unable to deploy the appliance to export domain using image uploader
Summary: unable to deploy the appliance to export domain using image uploader
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: oVirt
Classification: Retired
Component: ovirt-image-uploader
Version: 3.5
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 3.5.1
Assignee: Simone Tiraboschi
QA Contact: Pavel Stehlik
URL:
Whiteboard: integration
Depends On:
Blocks: 1029507 1190655
TreeView+ depends on / blocked
 
Reported: 2014-07-31 07:37 UTC by Petr Beňas
Modified: 2015-02-09 11:02 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-08 15:36:26 UTC
oVirt Team: ---


Attachments (Terms of Use)

Description Petr Beňas 2014-07-31 07:37:37 UTC
Description of problem:
[root@pb-rh35 ~]# engine-image-uploader -r pb-rh35.rhev.lab.eng.brq.redhat.com -e export upload oVirt-Engine-Appliance-Fedora-x86_64-19-20140711.ova 
Please provide the REST API password for the admin@internal oVirt Engine user (CTRL+D to abort): 
ERROR: Unable to calculate the decompressed size of oVirt-Engine-Appliance-Fedora-x86_64-19-20140711.ova.
[root@pb-rh35 ~]# rpm -qa ovirt-image-uploader
ovirt-image-uploader-3.5.0-0.1.master.20140711.gitc9fc39f.el6.noarch


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Fabian Deutsch 2014-08-01 15:53:45 UTC
The meta file of the image (inside the ova) looks sane:

DOMAIN=00000000-0000-0000-0000-000000000000
VOLTYPE=LEAF
CTIME=1405091237
FORMAT=COW
IMAGE=efc1b18e-eae1-4f71-af43-ca2138442329
DISKTYPE=1
PUUID=00000000-0000-0000-0000-000000000000
LEGALITY=LEGAL
MTIME=1405091237
POOL_UUID=00000000-0000-0000-0000-000000000000
SIZE=104857600
TYPE=SPARSE
DESCRIPTION=Uploaded by Image Factory
EOF

(But I am no ova expert).

Moving it to image-uploader for further debugging.

Comment 2 Simone Tiraboschi 2014-08-08 15:36:26 UTC
Unable to reproduce on f19 with oVirt 3.5.0 rc1 with a .ova downloaded from here:
http://jenkins.ovirt.org/job/ovirt-appliance_master_merged/118/
It uploads corretly


Note You need to log in before you can comment on or make changes to this bug.