Bug 1125328 - Error message is seen when doing jenkins build with vhost frontend plugin enabled on node.
Summary: Error message is seen when doing jenkins build with vhost frontend plugin ena...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Image
Version: 2.1.0
Hardware: Unspecified
OS: Unspecified
high
medium
Target Milestone: ---
: ---
Assignee: Brenton Leanhardt
QA Contact: libra bugs
URL:
Whiteboard:
Depends On: 1176651
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-31 15:09 UTC by Johnny Liu
Modified: 2019-07-11 08:05 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-04-06 17:05:51 UTC


Attachments (Terms of Use)
jenkins.log (56.96 KB, text/plain)
2014-12-24 03:22 UTC, Johnny Liu
no flags Details
openshift_log (14.30 KB, text/plain)
2014-12-24 03:23 UTC, Johnny Liu
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:0779 normal SHIPPED_LIVE Red Hat OpenShift Enterprise 2.2.5 bug fix and enhancement update 2015-04-06 21:05:45 UTC

Description Johnny Liu 2014-07-31 15:09:50 UTC
Description of problem:
When vhost frontend plugin is enabled on node, jenkins build will throw some error, while mod-rewrite does not.

Version-Release number of selected component (if applicable):
2.1.z/2014-07-28.1/

How reproducible:
Always

Steps to Reproduce:
1.Install node, and enable vhost frontend plugin on this node.
2.Create an ruby app, and add jenkins-client
3.Do some change, then git push to trigger jenkins build.

Actual results:
During jenkins build, the following error is seen in the output:
remote: /opt/rh/ruby193/root/usr/share/ruby/json/common.rb:155:in `parse': 757: unexpected token at '<!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN"> (JSON::ParserError)
remote: <html><head>
remote: <title>502 Proxy Error</title>
remote: </head><body>
remote: <h1>Proxy Error</h1>
remote: <p>The proxy server received an invalid
remote: response from an upstream server.<br />
remote: The proxy server could not handle the request <em><a href="/job/scaruby19app-build/api/json">GET&nbsp;/job/scaruby19app-build/api/json</a></em>.<p>
remote: Reason: <strong>Error reading from remote server</strong></p></p>
remote: <hr>
remote: <address>Apache/2.2.15 (Red Hat) Server at jenkinsapp-jialiu.ose-21.com.cn Port 443</address>
remote: </body></html>'
remote: 	from /opt/rh/ruby193/root/usr/share/ruby/json/common.rb:155:in `parse'
remote: 	from /var/lib/openshift/53da4913f13a7963780000e8/jenkins-client//bin/jenkins_build:27:in `get_jobs_info'
remote: 	from /var/lib/openshift/53da4913f13a7963780000e8/jenkins-client//bin/jenkins_build:46:in `is_cancelled'
remote: 	from /var/lib/openshift/53da4913f13a7963780000e8/jenkins-client//bin/jenkins_build:70:in `<main>'
remote: !!!!!!!!
remote: Deployment Halted!
remote: If the build failed before the deploy step, your previous
remote: build is still running.  Otherwise, your application may be
remote: partially deployed or inaccessible.
remote: Fix the build and try again.
remote: !!!!!!!!
remote: An error occurred executing 'gear postreceive' (exit code: 1)

Though jenkins build failed, the change takes effect.

If wait for some minutes (e.g: 5 mins), do jenkins build again, no error is seen.

Expected results:
No error is seen in the output.

Additional info:
When enable mod-rewrite frontend plugin, no such issue.

Comment 1 Luke Meyer 2014-10-28 15:13:15 UTC
I tried this a few times and couldn't reproduce the problem. Is there an element of timing to it? (E.g. only happens on an update within X minutes of creating the app...) Or perhaps it's just gone away with the latest 2.2.

Comment 2 Brenton Leanhardt 2014-10-28 17:56:45 UTC
I was able to reproduce this.  It seems like there's some sort of timeout problem.  I could fine 502s in /var/log/httpd/openshift_log matching the failed jenkins jobs.

In the jenkins logs I saw this error message around the time of the failure:
INFO: Checking to see if slave DNS for app2bldr-demo.ose22.example.com is resolvable ... (timeout: 300000ms)

I didn't see that error message for every 502 so I'm not completely convinced it's related.  In all cases the problem seemed to go away which is what is making it even harder to track down.

I'm going to propose we treat this as high priority for 2.2.z.

Comment 3 Johnny Liu 2014-12-23 01:57:58 UTC
*** Bug 1176649 has been marked as a duplicate of this bug. ***

Comment 8 Johnny Liu 2014-12-24 03:22:52 UTC
Created attachment 972621 [details]
jenkins.log

Comment 9 Johnny Liu 2014-12-24 03:23:29 UTC
Created attachment 972622 [details]
openshift_log

Comment 11 Johnny Liu 2015-03-19 07:57:34 UTC
Verified this bug with 2.2/2015-03-18.2 puddle, PASS.


remote: Executing Jenkins build.
remote: 
remote: You can track your build at https://jenkins-jialiu.ose-22.example.com/job/php53app-build
remote: 
remote: Waiting for build to schedule..............................Done
remote: Waiting for job to complete............Retrying job 1 lookup....Done.
remote: .....Done
remote: SUCCESS
remote: New build has been deployed.
remote: -------------------------
remote: Git Post-Receive Result: success
remote: Deployment completed with status: success


$ curl php53app-jialiu.ose-22.example.com|grep title
<title>We22lcome to OpenShift</title>

Comment 13 errata-xmlrpc 2015-04-06 17:05:51 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-0779.html


Note You need to log in before you can comment on or make changes to this bug.