Bug 1176651 - Deployment via git push fails if Jenkins is enabled on JBoss application but, the Jenkins build logs show that the build was a success
Summary: Deployment via git push fails if Jenkins is enabled on JBoss application but,...
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: OpenShift Online
Classification: Red Hat
Component: Image
Version: 2.x
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: ---
Assignee: Jakub Hadvig
QA Contact: libra bugs
URL:
Whiteboard:
Depends On:
Blocks: 1125328 1176649
TreeView+ depends on / blocked
 
Reported: 2014-12-22 17:55 UTC by Miheer Salunke
Modified: 2015-05-15 00:46 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of: 1176649
Environment:
Last Closed: 2015-01-12 19:11:27 UTC


Attachments (Terms of Use)

Description Miheer Salunke 2014-12-22 17:55:39 UTC
+++ This bug was initially created as a clone of Bug #1176649 +++

Description of problem:

Deployment via git push fails if Jenkins is enabled on JBoss application but, the Jenkins build logs show that the build was a success

Version-Release number of selected component (if applicable):
2.2

How reproducible:
Always

Steps to Reproduce:
1. Follow steps as mentioned in https://developers.openshift.com/en/managing-continuous-integration.html
2. Deploy using git push 


Actual results:
Results after git push 

    Pushing to ssh://549410074382ec2a8b0000ad@jbosseap-karandomain.rhcloud.com/~/git/jbosseap.git/
    Counting objects: 5, done.
    Delta compression using up to 4 threads.
    Compressing objects: 100% (3/3), done.
    Writing objects: 100% (3/3), 274 bytes, done.
    Total 3 (delta 2), reused 0 (delta 0)
    remote: Executing Jenkins build.
    remote:
    remote: You can track your build at https://jenkins-karandomain.rhcloud.com/job/jbosseap-build
    remote:
    remote: Waiting for build to schedule......Done
    remote: Waiting for job to complete.................................................../opt/rh/ruby193/root/usr/share/ruby/json/common.rb:155:in `parse': 757: unexpected token at '<!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN"> (JSON::ParserError)
    remote: <html><head>
    remote: <title>502 Proxy Error</title>
    remote: </head><body>
    remote: <h1>Proxy Error</h1>
    remote: <p>The proxy server received an invalid
    remote: response from an upstream server.<br />
    remote: The proxy server could not handle the request <em><a href="/job/jbosseap-build/2/api/json">GET&nbsp;/job/jbosseap-build/2/api/json</a></em>.<p>
    remote: Reason: <strong>Error reading from remote server</strong></p></p>
    remote: <hr>
    remote: <address>Apache/2.2.15 (Red Hat) Server at jenkins-karandomain.rhcloud.com Port 443</address>
    remote: </body></html>'
    remote:         from /opt/rh/ruby193/root/usr/share/ruby/json/common.rb:155:in `parse'
    remote:         from /var/lib/openshift/549410074382ec2a8b0000ad/jenkins-client//bin/jenkins_build:35:in `get_job_info'
    remote:         from /var/lib/openshift/549410074382ec2a8b0000ad/jenkins-client//bin/jenkins_build:91:in `<main>'
    remote: !!!!!!!!
    remote: Deployment Halted!
    remote: If the build failed before the deploy step, your previous
    remote: build is still running.  Otherwise, your application may be
    remote: partially deployed or inaccessible.
    remote: Fix the build and try again.
    remote: !!!!!!!!
    remote: An error occurred executing 'gear postreceive' (exit code: 1)
    remote: Error message: CLIENT_ERROR: Failed to execute: 'control post-receive' for /var/lib/openshift/549410074382ec2a8b0000ad/jenkins-client
    remote:
    remote: For more details about the problem, try running the command again with the '--trace' option.
    To ssh://549410074382ec2a8b0000ad@jbosseap-karandomain.rhcloud.com/~/git/jbosseap.git/
       2117087..b268c80  master -> master



Expected results:
The deployment using git push shall be a success.

Additional info:

Comment 2 Jakub Hadvig 2015-01-07 16:19:32 UTC
Could not reproduce this issue.
Tried both scaled and non-scaled jbossas-7 apps.

Comment 3 chunchen 2015-01-08 03:03:52 UTC
Also could not reproduce this issue.
Checked non-scaled jbossas-7 app on devenv_5381.

Comment 4 chunchen 2015-01-08 10:19:26 UTC
According to Comment #2 and Comment #3, mark this bug as VERIFIED.

Comment 5 Josep 'Pep' Turro Mauri 2015-01-09 12:21:48 UTC
(In reply to chunchen from comment #4)
> According to Comment #2 and Comment #3, mark this bug as VERIFIED.

To clarify: you mean that the problem was not reproducible? in that case, is this a suggestion to close as NOTABUG?  

Or is there a related code change to fix the bug here (that was verified)? If that's the case it would help to have further details (e.g. a pointer to that code change).

Comment 6 Luke Meyer 2015-01-09 14:33:42 UTC
(In reply to Josep 'Pep' Turro Mauri from comment #5)

QE doesn't close bugs.

The cloning of this bug omitted a number of comments left on the original Enterprise bug. It's a little tricky to reproduce, in fact I tried and never saw it, but Brenton did see it (and still couldn't quite debug it at the time). It's not clear the actual circumstances under which it occurs, and it may simply be intermittent based on timing and environment. So, "how reproducible: always" should be revised (perhaps to "we don't know, seems to happen a lot in some cases and never in others").

Jakub, could you maybe try a few times with JBossEAP? If it's related to timing, the cartridge details might be significant. Or if not... what information would be helpful to gather for debugging, by anyone who *can* reproduce this?

Comment 7 Jakub Hadvig 2015-01-12 10:05:12 UTC
@Luke
Thanks for comment. Will definitely play a little bit more with the JBossEAP cartridge.
Anyway recently there were 2 JBossEAP related bugs:
- 1175489
- 1176970
where the first one had the same scenario then this one. But different error result. In this term it may just be, that those mentioned issues may cause this issue as a side effect, but I'm not sure.
Anyway. Will create a script to create JBossEAP app, every n minutes, so will see.
Thanks

Comment 8 Jakub Hadvig 2015-01-12 18:42:07 UTC
@Luke
Today I've created approx. 30 jbosseap apps, with around 15 min interval and I couldn't reproduce this issue.
To be honest the only info that would be useful for debugging would be the  failing application itself.
Any thoughts ?
Thanks

Comment 9 Luke Meyer 2015-01-12 19:11:27 UTC
@Jakub it's possible only OSE is affected. If you have a minute to look at the comments/attachments in bug 1125328 and bug 1176649 and see if anything suggests a direction to look, we'd appreciate it. Otherwise, we'd probably best close this online bug until we can hand off an online devenv that reproduces the problem(s) with some frequency.


Note You need to log in before you can comment on or make changes to this bug.