Bug 1125423 - Fuse Fabric Groups Plugin cannot be enabled
Summary: Fuse Fabric Groups Plugin cannot be enabled
Status: CLOSED CURRENTRELEASE
Alias: None
Product: JBoss Operations Network
Classification: JBoss
Component: Plugin -- Other
Version: JON 3.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ER04
: JON 3.3.0
Assignee: Libor Zoubek
QA Contact: Mike Foley
URL:
Whiteboard:
Keywords:
: 1078528 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-31 19:24 UTC by Mike Foley
Modified: 2015-11-02 00:44 UTC (History)
6 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2014-12-11 14:01:14 UTC


Attachments (Terms of Use)
Fuse Fabric Group Plugin cannot be enabled (161.91 KB, image/png)
2014-07-31 19:24 UTC, Mike Foley
no flags Details

Description Mike Foley 2014-07-31 19:24:39 UTC
Created attachment 923026 [details]
Fuse Fabric Group Plugin cannot be enabled

Description of problem: Fuse Fabric Groups Plugin cannot be enabled


Version-Release number of selected component (if applicable):


How reproducible:
100%

Steps to Reproduce:
1. navigate the menu Administration/Server Plugins
2.  highlight the Fuse Fabric Groups Plugin
3.  click enabled

Actual results:
plugin stays disabled.

Expected results:
plugin is enabled

Additional info:

Comment 2 Larry O'Leary 2014-08-29 15:38:16 UTC
Issue seems to be that the Fuse Fabric Groups Plugin requires configuration. This configuration requires a user name and password for the Fabric instance. Because this configuration can not be provided by default, the plug-in is disabled and not able to be enabled until you provide the configuration.

Probably should make this clearer in the user-interface. For example: Enable / Disabled / Disabled / Needs Config.

Comment 4 Libor Zoubek 2014-09-23 13:40:31 UTC
*** Bug 1078528 has been marked as a duplicate of this bug. ***

Comment 6 Libor Zoubek 2014-09-25 12:32:24 UTC
branch:  master
link:    https://github.com/rhq-project/rhq/commit/bd1095fa5
time:    2014-09-25 14:26:42 +0200
commit:  bd1095fa5ac2f55544d5f8c4b45033b4050b94d9
author:  Libor Zoubek - lzoubek@redhat.com
message: Bug 1125423 - Fuse Fabric Groups Plugin cannot be enabled
         Generally when there is an attempt to enable server plugins we
         now first check it's configuration by looking for required
         properties (in ConfigDef) and making sure there's valid value
         in configuration. If something is missing, it means plugin is
         not configured and cannot be enabled. ServerPluginManagerBean
         thows this using PluginConfigurationRequiredException that is
         then presented to user.

Comment 8 Libor Zoubek 2014-09-26 14:15:00 UTC
branch:  master
link:    https://github.com/rhq-project/rhq/commit/c4fc397e5
time:    2014-09-26 16:13:59 +0200
commit:  c4fc397e59325e17fca9a06af93acd2d79015f20
author:  Libor Zoubek - lzoubek@redhat.com
message: Bug 1125423 - Fuse Fabric Groups Plugin cannot be enabled

         Fixed failing itest and also added test

Comment 9 Thomas Segismont 2014-09-26 14:31:57 UTC
Cherry-picked over to release/jon3.3.x



  Branch: refs/heads/release/jon3.3.x
  Home:   https://github.com/rhq-project/rhq
  Commit: 1459445b51a2214b674262dfd657a88866ae691a
      https://github.com/rhq-project/rhq/commit/1459445b51a2214b674262dfd657a88866ae691a
  Author: Libor Zoubek <lzoubek@redhat.com>
  Date:   2014-09-26 (Fri, 26 Sep 2014)

  Changed paths:
    A modules/core/domain/src/main/java/org/rhq/core/domain/plugin/PluginConfigurationRequiredException.java
    M modules/enterprise/gui/coregui/src/main/java/org/rhq/coregui/server/gwt/PluginGWTServiceImpl.java
    M modules/enterprise/server/jar/src/main/java/org/rhq/enterprise/server/plugin/ServerPluginManagerBean.java

  Log Message:
  -----------
  Bug 1125423 - Fuse Fabric Groups Plugin cannot be enabled

Generally when there is an attempt to enable server plugins we now first
check it's configuration by looking for required properties (in ConfigDef)
and making sure there's valid value in configuration. If something is
missing, it means plugin is not configured and cannot be enabled.
ServerPluginManagerBean thows this using
PluginConfigurationRequiredException that is then presented to user.

(cherry picked from commit bd1095fa5ac2f55544d5f8c4b45033b4050b94d9)
Signed-off-by: Thomas Segismont <tsegismo@redhat.com>


  Commit: b223cef6f2fb9af6db5d2030a0a8e61ac399eea3
      https://github.com/rhq-project/rhq/commit/b223cef6f2fb9af6db5d2030a0a8e61ac399eea3
  Author: Libor Zoubek <lzoubek@redhat.com>
  Date:   2014-09-26 (Fri, 26 Sep 2014)

  Changed paths:
    M modules/enterprise/server/itests-2/src/test/java/org/rhq/enterprise/server/plugin/ServerPluginsBeanTest.java
    M modules/enterprise/server/itests-2/src/test/java/org/rhq/enterprise/server/plugin/pc/generic/TestGenericServerPluginService.java

  Log Message:
  -----------
  Bug 1125423 - Fuse Fabric Groups Plugin cannot be enabled

Fixed failing itest and also added test

(cherry picked from commit c4fc397e59325e17fca9a06af93acd2d79015f20)
Signed-off-by: Thomas Segismont <tsegismo@redhat.com>


Compare: https://github.com/rhq-project/rhq/compare/b18999965418...b223cef6f2fb

Comment 10 Simeon Pinder 2014-10-01 21:33:17 UTC
Moving to ON_QA as available for test with build:
https://brewweb.devel.redhat.com/buildinfo?buildID=388959


Note You need to log in before you can comment on or make changes to this bug.