Bug 1125461 - KTouch needs the dependency kqtquickcharts packaged and added as a runtime dependency
Summary: KTouch needs the dependency kqtquickcharts packaged and added as a runtime de...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: ktouch
Version: rawhide
Hardware: All
OS: Linux
urgent
urgent
Target Milestone: ---
Assignee: Ngo Than
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1126113 (view as bug list)
Depends On: kqtquickcharts
Blocks: kde-4.13
TreeView+ depends on / blocked
 
Reported: 2014-07-31 22:55 UTC by Kevin Kofler
Modified: 2014-08-16 22:31 UTC (History)
7 users (show)

Fixed In Version: ktouch-4.13.3-2.fc20
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-16 22:31:32 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Gentoo 508060 None None None Never

Description Kevin Kofler 2014-07-31 22:55:02 UTC
Description of problem:
It was reported on IRC that KTouch is missing a runtime dependency:
file:///usr/share/kde4/apps/ktouch/qml/ProfileDetailsItem.qml:22:1: module "org.kde.charts" is not installed
This is kqtquickcharts, a new module that needs to be packaged in Fedora.

Version-Release number of selected component (if applicable):
ktouch-4.13.*
(This affects the 4.13.3 update pushed to Fedora 20, as well as Fedora 21 and Rawhide.)

Comment 1 Rex Dieter 2014-08-01 11:50:08 UTC
makes me wonder if we can work on some rpm dep autogenerators for qml stuff

Comment 2 Kevin Kofler 2014-08-02 11:01:15 UTC
*** Bug 1126113 has been marked as a duplicate of this bug. ***

Comment 3 Fedora Update System 2014-08-08 16:59:28 UTC
ktouch-4.13.3-2.fc20, kqtquickcharts-4.13.3-2.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/ktouch-4.13.3-2.fc20,kqtquickcharts-4.13.3-2.fc20

Comment 4 Fedora Update System 2014-08-09 07:33:03 UTC
Package ktouch-4.13.3-2.fc20, kqtquickcharts-4.13.3-2.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing ktouch-4.13.3-2.fc20 kqtquickcharts-4.13.3-2.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-9296/ktouch-4.13.3-2.fc20,kqtquickcharts-4.13.3-2.fc20
then log in and leave karma (feedback).

Comment 5 Fedora Update System 2014-08-16 22:31:32 UTC
ktouch-4.13.3-2.fc20, kqtquickcharts-4.13.3-2.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.