Bug 1125972 - JON 3.3 Administration/Affinity Groups page is incorrect. Button is missing to create new affinity group
Summary: JON 3.3 Administration/Affinity Groups page is incorrect. Button is missing ...
Status: CLOSED CURRENTRELEASE
Alias: None
Product: JBoss Operations Network
Classification: JBoss
Component: UI
Version: JON 3.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ER01
: JON 3.3.0
Assignee: Jirka Kremser
QA Contact: Mike Foley
URL:
Whiteboard:
Keywords:
: 1127523 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-01 13:30 UTC by Mike Foley
Modified: 2014-12-11 14:03 UTC (History)
3 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2014-12-11 14:03:02 UTC


Attachments (Terms of Use)
JON 3.3 Affinity Groups (110.19 KB, image/png)
2014-08-01 13:30 UTC, Mike Foley
no flags Details
JON 3.2.2 Affinity Groups (64.70 KB, image/png)
2014-08-01 13:31 UTC, Mike Foley
no flags Details

Description Mike Foley 2014-08-01 13:30:37 UTC
Created attachment 923321 [details]
JON 3.3 Affinity Groups

Description of problem:  JON 3.3 Administration/Affinity Groups page is incorrect.  Button is missing to create new affinity group


Version-Release number of selected component (if applicable):
JON 3.3

How reproducible:
100%

Steps to Reproduce:
1.  Menus ...Administration/Affinity Groups
2.
3.

Actual results:
no button to create a new affinity group

Expected results:
button to create a new affinity group

Additional info:
see attached screenshots from JON 3.3 and JON 3.2.2

Comment 1 Mike Foley 2014-08-01 13:31:03 UTC
Created attachment 923322 [details]
JON 3.2.2 Affinity Groups

Comment 2 Jirka Kremser 2014-08-05 00:25:56 UTC
branch:  master
link:    https://github.com/rhq-project/rhq/commit/ca1a0fd85
time:    2014-08-05 02:24:16 +0200
commit:  ca1a0fd855e2986cbb719d6bf501fd1dd2fa373f
author:  Jirka Kremser - jkremser@redhat.com
message: [BZ 1125972] - JON 3.3 Administration/Affinity Groups page is incorrect.
         Button is missing to create new affinity group - This issue was
         caused by spaces in id (BaseWidget.setID())

Comment 3 Jirka Kremser 2014-08-11 15:18:35 UTC
branch:  master
link:    https://github.com/rhq-project/rhq/commit/20eba2225
time:    2014-08-11 17:18:06 +0200
commit:  20eba2225c7b5e51cd495142208a305c48a482ec
author:  Jirka Kremser - jkremser@redhat.com
message: [BZ 1125972] - JON 3.3 Administration/Affinity Groups page is incorrect.
         Button is missing to create new affinity group - Using utility
         method for replacing spaces and other forbidden characters in
         smart gwt id field for UI components.

Comment 4 Jay Shaughnessy 2014-08-11 15:51:58 UTC
Moved to release branch for Jirka:

branch: release/jon3.3.x
link:   https://github.com/rhq-project/rhq/commit/363d9ac3e87ae98
commit: 363d9ac3e87ae9891a5018d39c4b3f7f967e6b7a
Author: Jay Shaughnessy <jshaughn@redhat.com>
Date:   Mon Aug 11 11:46:15 2014 -0400

    Cherry-pick master ca1a0fd855e2986cbb719d6bf501fd1dd2fa373f

branch: release/jon3.3.x
link:   https://github.com/rhq-project/rhq/commit/ e4d393f16762b
commit: e4d393f16762bd0b986655f67a059197249ab4ec
Author: Jay Shaughnessy <jshaughn@redhat.com>
Date:   Mon Aug 11 11:47:37 2014 -0400

    Cherry-pick master 20eba2225c7b5e51cd495142208a305c48a482ec

Comment 5 Jirka Kremser 2014-08-12 14:02:02 UTC
*** Bug 1127523 has been marked as a duplicate of this bug. ***

Comment 6 Simeon Pinder 2014-08-19 23:50:32 UTC
Moving to ON_QA as available to test in the following brew build:

https://brewweb.devel.redhat.com//buildinfo?buildID=379025


Note You need to log in before you can comment on or make changes to this bug.