Bug 1125999 - Content Dashboard: Sync Overview widget shows multiple statuses for a product, per each repo contained therein.
Summary: Content Dashboard: Sync Overview widget shows multiple statuses for a product...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: WebUI
Version: 6.0.3
Hardware: Unspecified
OS: Unspecified
medium
high vote
Target Milestone: Unspecified
Assignee: David Davis
QA Contact: Corey Welton
URL: http://projects.theforeman.org/issues...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-01 14:43 UTC by Corey Welton
Modified: 2016-04-22 15:05 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-09-11 12:28:38 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Foreman Issue Tracker 6918 None None None 2016-04-22 15:05:08 UTC

Description Corey Welton 2014-08-01 14:43:56 UTC
Description of problem:
I am not sure if this is related to the fix put in for bug #1121166

If user has a product, say, "sat6", and has a bunch of repos contained therein, upon syncing this product, an identical line item appears in the widget for each repo contained in the product.

Version-Release number of selected component (if applicable):
Satellite-6.0.4-RHEL-6-20140730.0

How reproducible:


Steps to Reproduce:
1.  Create a product called "sat6", with repos "sat6-main", "sat6-capsule", "sat6-common".
2.  Sync this product
3.  Content Dashboard > Sync Overview widget
4. View results.

Actual results:

Duplicate statuses appear in the widget, 'n' times, like:

sat6    Success  Fri, 01 Aug 2014 14:29:21 +0000

Where n = the number of repos contained in your product.

Expected results:



Additional info:

Comment 2 Partha Aji 2014-08-04 17:28:50 UTC
Created redmine issue http://projects.theforeman.org/issues/6918 from this bug

Comment 4 David Davis 2014-08-06 17:43:30 UTC
https://github.com/Katello/katello/pull/4525

Comment 5 Bryan Kearney 2014-08-11 16:04:49 UTC
Moving to POST since upstream bug http://projects.theforeman.org/issues/6918 has been closed
-------------
David Davis
Applied in changeset commit:katello|88f98982e512d0224152fcef05a1b8777297c6f3.

Comment 8 Corey Welton 2014-08-14 20:48:45 UTC
Verified in Satellite-6.0.4-RHEL-6-20140813.2

Comment 9 Bryan Kearney 2014-09-11 12:28:38 UTC
This was delivered with Satellite 6.0 which was released on 10 September 2014.


Note You need to log in before you can comment on or make changes to this bug.