Bug 1126064 - anaconda crashes when analyzing local disks (perhaps)
Summary: anaconda crashes when analyzing local disks (perhaps)
Keywords:
Status: CLOSED DUPLICATE of bug 1129239
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 20
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-01 18:05 UTC by Frantisek Hanzlik
Modified: 2014-09-04 17:33 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-09-04 17:33:47 UTC


Attachments (Terms of Use)
/var/tmp/ content as tar xz tarball (48.52 KB, application/x-xz-compressed-tar)
2014-08-01 18:05 UTC, Frantisek Hanzlik
no flags Details
/tmp content after crash from another installation (48.56 KB, application/octet-stream)
2014-08-29 10:58 UTC, Frantisek Hanzlik
no flags Details
anaconda-tb (298.92 KB, text/plain)
2014-08-29 16:13 UTC, David Shea
no flags Details

Description Frantisek Hanzlik 2014-08-01 18:05:09 UTC
Created attachment 923387 [details]
/var/tmp/ content as tar xz tarball

Description of problem:
installing from kickstart, with manual arranging disk partitions. After acknowledging start installation, anaconda format partitions and begin resolve package dependencies. After several minutes (still before own package installation) ends on fatal 'script error' in package mythweb (which was perhaps selected because I it was required by mythtv package which was specified in kickstart file).

When I comment out all myth* packages and start installation again, then anaconda crashes even before it display main configuration window (where is possible select installation sources, where to install, language, keyboard, network, etc.).
When only difference against previous attempt to install is perhaps fact that disk partitions was in second case formated, then it seems as problem may be there.

Czech sentence 'Chybný popisovač souboru' may be translated as 'bad file descriptor'.

Version-Release number of selected component (if applicable):
anaconda from F20 netinst iso image

Additional info:
1) I'm not sure when crashing in first install try is right too - maybe it would be better when acaconda intelligently omit package with 'script errors' or package which request it.

2) I report this issue now there manually, because when I try do automatic bugreport builded in anaconda, this end (during upload phase) with error:

--- Running report_Bugzilla ---
fatal: libcurl failed to execute the HTTP POST transaction, explaining:  Peer's Certificate has expired,
('report_Bugzilla' exited with 1)

and then only upload to backtrace server was possible (which i did - not sure what it is ;).
Attached is tar xz archive from /var/tmp/, which hopefully contains files created by anaconda after crash (which hopefully should be attached to automatic bugreport, if it was successful)

Comment 1 Frantisek Hanzlik 2014-08-03 08:39:46 UTC
Hmm, next installation attempt, made ​​by the same method, was successful.
Only difference against previous was that I set PCs clock (in previous installation was clock some as 01-Jan-2010 00:00, which is perhaps BIOS default).
IMO it could possibly affect the submission of a report to Bugzilla (maybe TLS layer check this), but not a installation itself.

Comment 2 Frantisek Hanzlik 2014-08-29 10:58:43 UTC
Created attachment 932623 [details]
/tmp content after crash from another installation

Another F20 x86_64 installation from kickstart, partitions were prepared before with gdisk. Now I tried install to two disks, /dev/sda (biosboot, /boot, swap, / with rest of the system) and sdb (/home and /mnt/data). Installation exits after formatting disks in "Starting package installation process" phase due to missing one dependent package in my repo (I miss here "Retry" button which was in old anaconda - then I could manually add the missing package and continue in installation. Now I have to repeat all installation from the beginning.). And when I start installation again, anaconda crashes with same error as described in this bugreport above ('OSError: [Errno 9] Bad file descriptor').

After I zeroed first several kB of each partitions sd{a,b}? then anaconda not crashed here (but then I have other problem later, as described in bug 1132658).

Comment 3 David Shea 2014-08-29 16:13:33 UTC
Created attachment 932740 [details]
anaconda-tb

Comment 4 David Shea 2014-09-04 17:33:47 UTC
Appears to be the same problem (or at least a related problem) as in bug 1129239

*** This bug has been marked as a duplicate of bug 1129239 ***


Note You need to log in before you can comment on or make changes to this bug.