Bug 1129239 - OSError: [Errno 9] Bad file descriptor
Summary: OSError: [Errno 9] Bad file descriptor
Keywords:
Status: CLOSED DUPLICATE of bug 1103450
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 20
Hardware: i686
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:11d46c1fd27085f984674d04af7...
: 1126064 1138906 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-12 11:16 UTC by Frantisek Hanzlik
Modified: 2014-10-13 14:12 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-10-13 14:12:01 UTC


Attachments (Terms of Use)
File: anaconda-tb (387.63 KB, text/plain)
2014-08-12 11:16 UTC, Frantisek Hanzlik
no flags Details
File: anaconda.log (5.10 KB, text/plain)
2014-08-12 11:16 UTC, Frantisek Hanzlik
no flags Details
File: environ (405 bytes, text/plain)
2014-08-12 11:16 UTC, Frantisek Hanzlik
no flags Details
File: ks.cfg (5.17 KB, text/plain)
2014-08-12 11:16 UTC, Frantisek Hanzlik
no flags Details
File: lsblk_output (5.17 KB, text/plain)
2014-08-12 11:16 UTC, Frantisek Hanzlik
no flags Details
File: nmcli_dev_list (2.38 KB, text/plain)
2014-08-12 11:16 UTC, Frantisek Hanzlik
no flags Details
File: os_info (375 bytes, text/plain)
2014-08-12 11:16 UTC, Frantisek Hanzlik
no flags Details
File: program.log (44.86 KB, text/plain)
2014-08-12 11:16 UTC, Frantisek Hanzlik
no flags Details
File: storage.log (187.11 KB, text/plain)
2014-08-12 11:16 UTC, Frantisek Hanzlik
no flags Details
File: syslog (94.05 KB, text/plain)
2014-08-12 11:16 UTC, Frantisek Hanzlik
no flags Details
File: ifcfg.log (2.70 KB, text/plain)
2014-08-12 11:16 UTC, Frantisek Hanzlik
no flags Details

Description Frantisek Hanzlik 2014-08-12 11:16:10 UTC
Description of problem:
installing from kickstart, anaconda crashes in early phase (after reading kickstart and %include files over http)

Version-Release number of selected component:
anaconda-20.25.15-1

The following was filed automatically by anaconda:
anaconda 20.25.15-1 exception report
Traceback (most recent call first):
  File "/usr/lib/python2.7/subprocess.py", line 747, in __init__
    self.stdout = os.fdopen(c2pread, 'rb', bufsize)
  File "/usr/lib/python2.7/site-packages/blivet/util.py", line 40, in _run_program
    preexec_fn=chroot, cwd=root, env=env)
  File "/usr/lib/python2.7/site-packages/blivet/util.py", line 56, in run_program
    return _run_program(*args, **kwargs)[0]
  File "/usr/lib/python2.7/site-packages/blivet/udev.py", line 86, in udev_settle
    util.run_program(["udevadm", "settle", "--timeout=300"])
  File "/usr/lib/python2.7/site-packages/blivet/devices.py", line 745, in _preTeardown
    udev_settle()
  File "/usr/lib/python2.7/site-packages/blivet/devices.py", line 756, in teardown
    if not self._preTeardown(recursive=recursive):
  File "/usr/lib/python2.7/site-packages/blivet/devicetree.py", line 2001, in teardownAll
    device.teardown(recursive=True)
  File "/usr/lib/python2.7/site-packages/blivet/devicetree.py", line 1970, in _populate
    self.teardownAll()
  File "/usr/lib/python2.7/site-packages/blivet/devicetree.py", line 1906, in populate
    self._populate()
  File "/usr/lib/python2.7/site-packages/blivet/__init__.py", line 416, in reset
    self.devicetree.populate(cleanupOnly=cleanupOnly)
  File "/usr/lib/python2.7/site-packages/blivet/__init__.py", line 142, in storageInitialize
    storage.reset()
  File "/usr/lib/python2.7/threading.py", line 764, in run
    self.__target(*self.__args, **self.__kwargs)
  File "/usr/lib/python2.7/site-packages/pyanaconda/threads.py", line 192, in run
    threading.Thread.run(self, *args, **kwargs)
OSError: [Errno 9] Bad file descriptor

Additional info:
cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   initrd=initrd.img inst.stage2=hd:LABEL=Fedora\x2020\x20i386 ks=http://192.168.1.22/ks/20/nas.zamecek32-ks.cfg BOOT_IMAGE=vmlinuz 
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         3.11.10-301.fc20.i686
product:        Fedora
release:        Cannot get release name.
type:           anaconda
version:        20

Comment 1 Frantisek Hanzlik 2014-08-12 11:16:14 UTC
Created attachment 926040 [details]
File: anaconda-tb

Comment 2 Frantisek Hanzlik 2014-08-12 11:16:16 UTC
Created attachment 926041 [details]
File: anaconda.log

Comment 3 Frantisek Hanzlik 2014-08-12 11:16:17 UTC
Created attachment 926042 [details]
File: environ

Comment 4 Frantisek Hanzlik 2014-08-12 11:16:18 UTC
Created attachment 926043 [details]
File: ks.cfg

Comment 5 Frantisek Hanzlik 2014-08-12 11:16:19 UTC
Created attachment 926044 [details]
File: lsblk_output

Comment 6 Frantisek Hanzlik 2014-08-12 11:16:20 UTC
Created attachment 926045 [details]
File: nmcli_dev_list

Comment 7 Frantisek Hanzlik 2014-08-12 11:16:22 UTC
Created attachment 926046 [details]
File: os_info

Comment 8 Frantisek Hanzlik 2014-08-12 11:16:24 UTC
Created attachment 926047 [details]
File: program.log

Comment 9 Frantisek Hanzlik 2014-08-12 11:16:26 UTC
Created attachment 926048 [details]
File: storage.log

Comment 10 Frantisek Hanzlik 2014-08-12 11:16:28 UTC
Created attachment 926049 [details]
File: syslog

Comment 11 Frantisek Hanzlik 2014-08-12 11:16:29 UTC
Created attachment 926050 [details]
File: ifcfg.log

Comment 12 David Shea 2014-09-04 17:33:47 UTC
*** Bug 1126064 has been marked as a duplicate of this bug. ***

Comment 13 David Shea 2014-09-08 13:12:50 UTC
*** Bug 1138906 has been marked as a duplicate of this bug. ***

Comment 14 David Shea 2014-10-13 14:12:01 UTC

*** This bug has been marked as a duplicate of bug 1103450 ***


Note You need to log in before you can comment on or make changes to this bug.