Bug 112619 - unresolved symbols while installing
Summary: unresolved symbols while installing
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: kernel (Show other bugs)
(Show other bugs)
Version: 1.0
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Dave Jones
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
: 112834 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-12-24 18:45 UTC by Kaj J. Niemi
Modified: 2015-01-04 22:04 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-01-10 14:48:21 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Kaj J. Niemi 2003-12-24 18:45:27 UTC
Description of problem:
Lots of unnecessary output regarding unresolved symbols when
installing 2.6.0-1.21

Version-Release number of selected component (if applicable):
2.6.0-1.21

How reproducible:
Always

Steps to Reproduce:
1. rpm -ivh kernel-2.6.0-1.21.i686.rpm
2.
3.
  
Actual results:
WARNING:
/lib/modules/2.6.0-1.21/unsupported/drivers/video/sis/sisfb.ko needs
unknown symbol __floatsidf
WARNING:
/lib/modules/2.6.0-1.21/unsupported/drivers/video/sis/sisfb.ko needs
unknown symbol __fixunsdfsi
WARNING:
/lib/modules/2.6.0-1.21/unsupported/drivers/video/sis/sisfb.ko needs
unknown symbol __adddf3
WARNING:
/lib/modules/2.6.0-1.21/unsupported/drivers/video/sis/sisfb.ko needs
unknown symbol __divdf3
copy from /lib/modules/2.6.0-1.21/./kernel/fs/jbd/jbd.ko(elf32-i386)
to /tmp/initrd.sM4925/lib/jbd.ko(elf32-i 386)
copy from /lib/modules/2.6.0-1.21/./kernel/fs/ext3/ext3.ko(elf32-i386)
to /tmp/initrd.sM4925/lib/ext3.ko(elf3 2-i386)


Expected results:
No output

Additional info:
I think they're internal names of floating point functions in libgcc?
Wasn't there something a short while ago that the kernel isn't
supposed to have floating point stuff?

Comment 1 Arjan van de Ven 2003-12-24 18:56:34 UTC
this is why the sis driver is in the kernel-unsupported rpm and not in
the main rpm....


Comment 2 Kaj J. Niemi 2003-12-24 19:34:56 UTC
There is no more kernel-unsupported rpm?

Besides what's the use of having the sis driver when it most likely
won't work without someone relinking it against libgcc?

Comment 3 Arjan van de Ven 2003-12-24 19:37:25 UTC
Dave: seems you broke something and this guy now has 2 pieces ;)

Comment 4 Kaj J. Niemi 2003-12-24 19:54:03 UTC
I've got enough presents already, no more pieces for me thanks ;-)
Merry xmas :)



Comment 5 Alan Sanderson 2004-01-04 06:41:57 UTC
*** Bug 112834 has been marked as a duplicate of this bug. ***

Comment 6 Kaj J. Niemi 2004-01-10 14:48:21 UTC
No more unresolved symbols while installing kernel-2.6.0-1.34. I'll
resolve as RAWHIDE or something..


Note You need to log in before you can comment on or make changes to this bug.