Bug 112628 - xfs doesn't compile
xfs doesn't compile
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
: 110661 (view as bug list)
Depends On: 66513
Blocks:
  Show dependency treegraph
 
Reported: 2003-12-24 17:22 EST by David Nečas
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-02-19 16:41:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch (1.48 KB, patch)
2003-12-24 17:27 EST, David Nečas
no flags Details | Diff

  None (edit)
Description David Nečas 2003-12-24 17:22:19 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.10 (X11; Linux i686; U;) Gecko/20030314

Description of problem:
XFS doesn't compile. One gets

...
gcc32 -D__KERNEL__ -I/none/src/linux-2.4.22-1.2135.nptl/include -Wall
-Wstrict-prototypes -Wno-trigraphs -O2 -fno-strict-aliasing
-fno-common -fomit-frame-pointer -pipe -mpreferred-stack-boundary=2
-march=athlon -DMODULE -DMODVERSIONS -include
/none/src/linux-2.4.22-1.2135.nptl/include/linux/modversions.h -I..
-nostdinc -iwithprefix include -DKBUILD_BASENAME=page_buf 
-DEXPORT_SYMTAB -c page_buf.c
page_buf.c: In function `pagebuf_iodone_daemon':
page_buf.c:1923: structure has no member named `sigmask_lock'
page_buf.c:1925: too many arguments to function
`recalc_sigpending_Rfb6af58d'
page_buf.c:1929: warning: statement with no effect
page_buf.c: In function `pagebuf_daemon':
page_buf.c:2024: structure has no member named `sigmask_lock'
page_buf.c:2026: too many arguments to function
`recalc_sigpending_Rfb6af58d'
make[3]: *** [page_buf.o] Error 1
make[3]: Leaving directory
`/none/src/linux-2.4.22-1.2135.nptl/fs/xfs/pagebuf'
make[2]: *** [_modsubdir_pagebuf] Error 2
make[2]: Leaving directory `/none/src/linux-2.4.22-1.2135.nptl/fs/xfs'
make[1]: *** [_modsubdir_xfs] Error 2
make[1]: Leaving directory `/none/src/linux-2.4.22-1.2135.nptl/fs'
make: *** [_mod_fs] Error 2

when trying it.

Version-Release number of selected component (if applicable):
kernel-source-2.4.22-1.2135.nptl

How reproducible:
Always

Steps to Reproduce:
1. select XFS as a module in kernel config
2. run make dep && make modules

    

Actual Results:  Compilation fails, with the errors listed above.

Expected Results:  It compiles.

Additional info:
Comment 1 David Nečas 2003-12-24 17:27:55 EST
Created attachment 96694 [details]
patch

The patch is only a formal change. I'm not sure about the semantics.
Comment 2 Dave Jones 2004-02-19 16:41:58 EST
it very likely will also need updating, as its changed quite a bit
since 2.4.22 (on which FC1 is based).  I don't have the spare cycles
to do that, so this is unlikely to happen before FC2. (where its
already merged)
Comment 3 Ales Ledvinka 2004-02-23 19:01:46 EST
*** Bug 110661 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.