Bug 1126293 - Add Users dialog has too much padding below the users grid
Summary: Add Users dialog has too much padding below the users grid
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: Frontend.WebAdmin
Version: 3.5.0
Hardware: Unspecified
OS: Unspecified
low
low vote
Target Milestone: ovirt-4.2.0
: ---
Assignee: Greg Sheremeta
QA Contact: samuel macko
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-04 06:00 UTC by Kobi Hakimi
Modified: 2019-04-28 14:34 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
undefined
Clone Of:
Environment:
Last Closed: 2017-12-20 11:35:56 UTC
oVirt Team: UX
rule-engine: ovirt-4.2?
pstehlik: testing_plan_complete-
rule-engine: planning_ack?
rule-engine: devel_ack+
pstehlik: testing_ack+


Attachments (Terms of Use)
The list should stretch to all page (26.15 KB, image/png)
2014-08-04 06:00 UTC, Kobi Hakimi
no flags Details
looks good in 4.2 (24.40 KB, image/png)
2017-11-30 17:41 UTC, Greg Sheremeta
no flags Details


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 31043 master ABANDONED webadmin: 'Add Users and Groups' dialog the list should stretch to all page Never
Red Hat Bugzilla 966427 None None None Never

Internal Links: 966427

Description Kobi Hakimi 2014-08-04 06:00:06 UTC
Created attachment 923776 [details]
The list should stretch to all page

Description of problem:
[RHEVM GUI] in 'Add Users and Groups' dialog The list should stretch to all page.

Version-Release number of selected component (if applicable):
 Red Hat Enterprise Virtualization Manager Version: 3.4.0-0.21.el6ev 
 oVirt Engine Version: 3.5.0-0.0.master.20140715172116.git4687dc1.el6 

How reproducible:
Always

Steps to Reproduce:
Go to Users tab and click on Add.

Actual results:
The 'Add Users and Groups' Dialog opened with unused space in the bottom of the list.

Expected results:
To use all the dialog space to present the users and groups list.

Additional info:
see attached snapshot

Comment 1 Einav Cohen 2014-08-15 15:30:20 UTC
this dialog is being used also for adding permissions, I am guessing that the leftover space at the bottom is the one used to display the Role drop-down in case of permissions granting. 

we have a similar issue in the confirmation dialog (see bug 966427), not sure if there is a quick and easy solution for this issue.

Comment 2 Einav Cohen 2014-08-15 15:30:58 UTC
[moving to 'NEW', even though there is a patch, since the patch doesn't seem to solve the problem properly]

Comment 3 Einav Cohen 2015-04-20 21:55:19 UTC
we will look into that when migrating dialogs to PatternFly.

Comment 4 Red Hat Bugzilla Rules Engine 2016-03-06 13:26:51 UTC
Bug tickets must have version flags set prior to targeting them to a release. Please ask maintainer to set the correct version flags and only then set the target milestone.

Comment 5 Red Hat Bugzilla Rules Engine 2017-11-30 17:41:02 UTC
This request has been proposed for two releases. This is invalid flag usage. The ovirt-future release flag has been cleared. If you wish to change the release flag, you must clear one release flag and then set the other release flag to ?.

Comment 6 Greg Sheremeta 2017-11-30 17:41:37 UTC
Created attachment 1361085 [details]
looks good in 4.2

Comment 7 RHV Bugzilla Automation and Verification Bot 2017-12-06 16:02:37 UTC
Where is the relevant tracker for this bug? I see one which is abandoned?
On which engine version was this fixed?

Comment 8 RHV Bugzilla Automation and Verification Bot 2017-12-06 16:17:23 UTC
INFO: Bug status wasn't changed from MODIFIED to ON_QA due to the following reason:

[No relevant external trackers attached]

For more info please contact: infra@ovirt.org

Comment 9 Greg Sheremeta 2017-12-06 18:08:44 UTC
It was fixed in the 4.2 redesign, but I have no idea which specific patch.

Comment 10 samuel macko 2017-12-19 14:03:23 UTC
Verified in RHEVM 4.2.0.2-0.1.el7

Verified by following the reproducer.

Comment 11 Sandro Bonazzola 2017-12-20 11:35:56 UTC
This bugzilla is included in oVirt 4.2.0 release, published on Dec 20th 2017.

Since the problem described in this bug report should be
resolved in oVirt 4.2.0 release, published on Dec 20th 2017, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.


Note You need to log in before you can comment on or make changes to this bug.