Bug 1126766 - Sub-package RPMs need to match RHEL 6.6 RPMs
Summary: Sub-package RPMs need to match RHEL 6.6 RPMs
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Containers
Version: 2.0.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: ---
Assignee: Brenton Leanhardt
QA Contact: libra bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-05 08:42 UTC by Anping Li
Modified: 2016-10-28 13:53 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-10-28 13:53:31 UTC


Attachments (Terms of Use)

Description Anping Li 2014-08-05 08:42:22 UTC
Description of problem:
Dependence error appear when install OSE2.0 on RHEL 6.6. 

Error: Package: libcgroup-pam-0.40.rc1-5.el6_5.1.x86_64 (openshift_node_puddle)
           Requires: libcgroup = 0.40.rc1-5.el6_5.1
           Available: libcgroup-0.40.rc1-10.el6.i686 (rhel_extra)
               libcgroup = 0.40.rc1-10.el6
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest


Version-Release number of selected component (if applicable):
2.0.z/2014-07-30.1

How reproducible:
Allays

Steps to Reproduce:
1. Install OS RHEL-6.6(RHEL-6.6-20140731.1)
2. Install 2.0.z/2014-07-30.1 

Actual results:

Error: Package: libcgroup-pam-0.40.rc1-5.el6_5.1.x86_64 (openshift_node_puddle)
           Requires: libcgroup = 0.40.rc1-5.el6_5.1
           Available: libcgroup-0.40.rc1-10.el6.i686 (rhel_extra)
               libcgroup = 0.40.rc1-10.el6
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

Expected results:
OSE2.0z can be installed on RHEL 6.6.

Additional info:

Comment 1 Anping Li 2014-08-05 08:43:40 UTC
There should be same problem on OSE2.1 and OSE1.2

Comment 3 Anping Li 2014-08-05 09:12:45 UTC
This issue is blocking regression testing. We expected it was fixed soon. thanks

Comment 4 Luke Meyer 2014-08-05 13:02:20 UTC
This is the same problem we usually have when shipping sub-package RPMs corresponding to RHEL or SCL builds. libcgroup builds both libcgroup and libcgroup-pam, but libcgroup ships in RHEL and we have to ship corresponding libcgroup-pam. If libcgroup is updated in RHEL and the update is installed on the system, the non-updated libcgroup-pam can't be installed.

A workaround is to yum downgrade libcgroup to the same version as the provided libcgroup-pam so that both can be installed, then continue the install. Alternatively (for internal testers), get the updated libcgroup from brew - that's what we'll have to test and ship anyway.

Several packages are likely to need this treatment, e.g. yum-plugin-priorities from yum-utils. Assuming there are multiple, let's use this bug could be used to track all of them. Chances are they will be needed for 1.2, 2.0, and 2.1 as you say. What we'll do is have an advisory for each that ships whenever RHEL 6.6 ships.

For testing we may need separate OSE puddles to match the RHEL 6.6 base.

Comment 5 Brenton Leanhardt 2014-08-05 13:09:08 UTC
Actually, thinking about this now we should only need to configure a multi-product release for libcgroup for our package.  I'll talk with RCM about this.

Comment 6 Luke Meyer 2014-08-05 13:28:53 UTC
php subpackages also have same issue, whether from current CDN or from OSE 2.1.5. In fact these have an imminent update in RHEL 6.5.z, but we can probably assume a 6.6 update too.

Install the openshift-origin-cartridge-dependencies-optional-php
Error: Package: php-process-5.3.3-27.el6_5.x86_64 (openshift_node_cdn)
           Requires: php-common(x86-64) = 5.3.3-27.el6_5
           Updated By: php-common-5.3.3-36.el6.x86_64 (rhel_extra)
Error: Package: php-mbstring-5.3.3-27.el6_5.x86_64 (openshift_node_cdn)
Error: Package: php-intl-5.3.3-27.el6_5.x86_64 (openshift_node_cdn)
Error: Package: php-bcmath-5.3.3-27.el6_5.x86_64 (openshift_node_cdn)
Error: Package: php-fpm-5.3.3-27.el6_5.x86_64 (openshift_node_cdn)
Error: Package: php-imap-5.3.3-27.el6_5.x86_64 (openshift_node_cdn)
Error: Package: php-devel-5.3.3-27.el6_5.x86_64 (openshift_node_cdn)

Error: Package: php-imap-5.3.3-27.el6_5.x86_64 (openshift_node_extra)
Error: Package: php-intl-5.3.3-27.el6_5.x86_64 (openshift_node_extra)
Error: Package: php-mbstring-5.3.3-27.el6_5.x86_64 (openshift_node_extra)
Error: Package: php-process-5.3.3-27.el6_5.x86_64 (openshift_node_extra)
Error: Package: php-devel-5.3.3-27.el6_5.x86_64 (openshift_node_extra)
Error: Package: php-bcmath-5.3.3-27.el6_5.x86_64 (openshift_node_extra)
Error: Package: php-fpm-5.3.3-27.el6_5.x86_64 (openshift_node_extra)

Comment 7 Luke Meyer 2014-08-05 13:29:46 UTC
*** Bug 1126799 has been marked as a duplicate of this bug. ***

Comment 9 Ma xiaoqiang 2014-08-06 02:21:09 UTC
After add the following repo, install the optional package successfully . 
[openshift-rhel-6.6-deps]
name=OpenShift Enterprise RHEL 6.6 dependencies
baseurl=$url
enabled=1
gpgcheck=0
priority=10
sslverify=false


Move the bug to VERIFIED.

Comment 11 Anping Li 2014-08-06 03:36:37 UTC
With this repo.
OSE 1.2.z/2014-07-09.2 can be installed on RHEL6.6.
OSE 2.1.z/2014-08-04.1 can be installed on RHEL6.6.
OSE 2.0.z/2014-08-05.1 can be installed on RHEL6.6.


Note You need to log in before you can comment on or make changes to this bug.