Bug 1126799 - Can not install php cartridge optional packages on RHEL6.6
Summary: Can not install php cartridge optional packages on RHEL6.6
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer
Version: 2.1.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: ---
Assignee: Luke Meyer
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-05 10:21 UTC by Ma xiaoqiang
Modified: 2016-07-04 00:45 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-05-12 16:36:31 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1065 normal SHIPPED_LIVE Red Hat OpenShift Enterprise atomic-openshift-utils bug fix update 2016-05-12 20:32:56 UTC

Description Ma xiaoqiang 2014-08-05 10:21:46 UTC
Description of problem:
Can not install php cartridge optional packages on RHEL6.6

Version-Release number of selected component (if applicable):
puddle [2.1.5/2014-08-04.1]

How reproducible:
100%

Steps to Reproduce:
1. Install New OS RHEL-6.6 (RHEL-6.6-20140731.1)
2. Enable RHEL-6.5 Repo and enable RHEL-6.6 Repo
3. Install the openshift-origin-cartridge-dependencies-optional-php.noarch

Actual results:
Output:
--> Finished Dependency Resolution
Error: Package: php-process-5.3.3-27.el6_5.x86_64 (openshift_node_cdn)
           Requires: php-common(x86-64) = 5.3.3-27.el6_5
           Removing: php-common-5.3.3-27.el6_5.x86_64 (@rhel6)
               php-common(x86-64) = 5.3.3-27.el6_5
           Updated By: php-common-5.3.3-36.el6.x86_64 (rhel_extra)
               php-common(x86-64) = 5.3.3-36.el6
           Available: php-common-5.3.2-6.el6.x86_64 (rhel6)
               php-common(x86-64) = 5.3.2-6.el6
           Available: php-common-5.3.2-6.el6_0.1.x86_64 (rhel6)
               php-common(x86-64) = 5.3.2-6.el6_0.1
           Available: php-common-5.3.3-3.el6.x86_64 (rhel6)
               php-common(x86-64) = 5.3.3-3.el6
           Available: php-common-5.3.3-3.el6_1.3.x86_64 (rhel6)
               php-common(x86-64) = 5.3.3-3.el6_1.3
           Available: php-common-5.3.3-3.el6_2.5.x86_64 (rhel6)
               php-common(x86-64) = 5.3.3-3.el6_2.5
           Available: php-common-5.3.3-3.el6_2.6.x86_64 (rhel6)
               php-common(x86-64) = 5.3.3-3.el6_2.6
           Available: php-common-5.3.3-3.el6_2.8.x86_64 (rhel6)
               php-common(x86-64) = 5.3.3-3.el6_2.8
           Available: php-common-5.3.3-14.el6_3.x86_64 (rhel6)
               php-common(x86-64) = 5.3.3-14.el6_3
           Available: php-common-5.3.3-22.el6.x86_64 (rhel6)
               php-common(x86-64) = 5.3.3-22.el6
           Available: php-common-5.3.3-23.el6_4.x86_64 (rhel6)
               php-common(x86-64) = 5.3.3-23.el6_4
           Available: php-common-5.3.3-26.el6.x86_64 (rhel6)
               php-common(x86-64) = 5.3.3-26.el6
Error: Package: php-imap-5.3.3-27.el6_5.x86_64 (openshift_node_extra)
           Requires: php-common(x86-64) = 5.3.3-27.el6_5
           Removing: php-common-5.3.3-27.el6_5.x86_64 (@rhel6)
               php-common(x86-64) = 5.3.3-27.el6_5
           Updated By: php-common-5.3.3-36.el6.x86_64 (rhel_extra)
               php-common(x86-64) = 5.3.3-36.el6
           Available: php-common-5.3.2-6.el6.x86_64 (rhel6)
               php-common(x86-64) = 5.3.2-6.el6
           Available: php-common-5.3.2-6.el6_0.1.x86_64 (rhel6)
               php-common(x86-64) = 5.3.2-6.el6_0.1
           Available: php-common-5.3.3-3.el6.x86_64 (rhel6)
               php-common(x86-64) = 5.3.3-3.el6
           Available: php-common-5.3.3-3.el6_1.3.x86_64 (rhel6)
               php-common(x86-64) = 5.3.3-3.el6_1.3
           Available: php-common-5.3.3-3.el6_2.5.x86_64 (rhel6)
               php-common(x86-64) = 5.3.3-3.el6_2.5
           Available: php-common-5.3.3-3.el6_2.6.x86_64 (rhel6)
               php-common(x86-64) = 5.3.3-3.el6_2.6
           Available: php-common-5.3.3-3.el6_2.8.x86_64 (rhel6)
               php-common(x86-64) = 5.3.3-3.el6_2.8
           Available: php-common-5.3.3-14.el6_3.x86_64 (rhel6)
               php-common(x86-64) = 5.3.3-14.el6_3
           Available: php-common-5.3.3-22.el6.x86_64 (rhel6)
               php-common(x86-64) = 5.3.3-22.el6
           Available: php-common-5.3.3-23.el6_4.x86_64 (rhel6)
               php-common(x86-64) = 5.3.3-23.el6_4
           Available: php-common-5.3.3-26.el6.x86_64 (rhel6)
               php-common(x86-64) = 5.3.3-26.el6
Error: Package: php-mbstring-5.3.3-27.el6_5.x86_64 (openshift_node_cdn)
           Requires: php-common(x86-64) = 5.3.3-27.el6_5
           Removing: php-common-5.3.3-27.el6_5.x86_64 (@rhel6)
               php-common(x86-64) = 5.3.3-27.el6_5
           Updated By: php-common-5.3.3-36.el6.x86_64 (rhel_extra)
               php-common(x86-64) = 5.3.3-36.el6
           Available: php-common-5.3.2-6.el6.x86_64 (rhel6)
               php-common(x86-64) = 5.3.2-6.el6
           Available: php-common-5.3.2-6.el6_0.1.x86_64 (rhel6)
               php-common(x86-64) = 5.3.2-6.el6_0.1
           Available: php-common-5.3.3-3.el6.x86_64 (rhel6)
               php-common(x86-64) = 5.3.3-3.el6
           Available: php-common-5.3.3-3.el6_1.3.x86_64 (rhel6)
               php-common(x86-64) = 5.3.3-3.el6_1.3
           Available: php-common-5.3.3-3.el6_2.5.x86_64 (rhel6)
               php-common(x86-64) = 5.3.3-3.el6_2.5
           Available: php-common-5.3.3-3.el6_2.6.x86_64 (rhel6)
               php-common(x86-64) = 5.3.3-3.el6_2.6
           Available: php-common-5.3.3-3.el6_2.8.x86_64 (rhel6)
               php-common(x86-64) = 5.3.3-3.el6_2.8
           Available: php-common-5.3.3-14.el6_3.x86_64 (rhel6)
               php-common(x86-64) = 5.3.3-14.el6_3
           Available: php-common-5.3.3-22.el6.x86_64 (rhel6)
               php-common(x86-64) = 5.3.3-22.el6
           Available: php-common-5.3.3-23.el6_4.x86_64 (rhel6)
               php-common(x86-64) = 5.3.3-23.el6_4
           Available: php-common-5.3.3-26.el6.x86_64 (rhel6)
               php-common(x86-64) = 5.3.3-26.el6
Error: Package: php-intl-5.3.3-27.el6_5.x86_64 (openshift_node_cdn)
           Requires: php-common(x86-64) = 5.3.3-27.el6_5
           Removing: php-common-5.3.3-27.el6_5.x86_64 (@rhel6)
               php-common(x86-64) = 5.3.3-27.el6_5
           Updated By: php-common-5.3.3-36.el6.x86_64 (rhel_extra)
               php-common(x86-64) = 5.3.3-36.el6
           Available: php-common-5.3.2-6.el6.x86_64 (rhel6)
               php-common(x86-64) = 5.3.2-6.el6
           Available: php-common-5.3.2-6.el6_0.1.x86_64 (rhel6)
               php-common(x86-64) = 5.3.2-6.el6_0.1
           Available: php-common-5.3.3-3.el6.x86_64 (rhel6)
               php-common(x86-64) = 5.3.3-3.el6
           Available: php-common-5.3.3-3.el6_1.3.x86_64 (rhel6)
               php-common(x86-64) = 5.3.3-3.el6_1.3
           Available: php-common-5.3.3-3.el6_2.5.x86_64 (rhel6)
               php-common(x86-64) = 5.3.3-3.el6_2.5
           Available: php-common-5.3.3-3.el6_2.6.x86_64 (rhel6)
               php-common(x86-64) = 5.3.3-3.el6_2.6
           Available: php-common-5.3.3-3.el6_2.8.x86_64 (rhel6)
               php-common(x86-64) = 5.3.3-3.el6_2.8
           Available: php-common-5.3.3-14.el6_3.x86_64 (rhel6)
               php-common(x86-64) = 5.3.3-14.el6_3
           Available: php-common-5.3.3-22.el6.x86_64 (rhel6)
               php-common(x86-64) = 5.3.3-22.el6
           Available: php-common-5.3.3-23.el6_4.x86_64 (rhel6)
               php-common(x86-64) = 5.3.3-23.el6_4
           Available: php-common-5.3.3-26.el6.x86_64 (rhel6)
               php-common(x86-64) = 5.3.3-26.el6
Error: Package: php-intl-5.3.3-27.el6_5.x86_64 (openshift_node_extra)
           Requires: php-common(x86-64) = 5.3.3-27.el6_5
           Removing: php-common-5.3.3-27.el6_5.x86_64 (@rhel6)
               php-common(x86-64) = 5.3.3-27.el6_5
           Updated By: php-common-5.3.3-36.el6.x86_64 (rhel_extra)
               php-common(x86-64) = 5.3.3-36.el6
           Available: php-common-5.3.2-6.el6.x86_64 (rhel6)
               php-common(x86-64) = 5.3.2-6.el6
           Available: php-common-5.3.2-6.el6_0.1.x86_64 (rhel6)
               php-common(x86-64) = 5.3.2-6.el6_0.1
           Available: php-common-5.3.3-3.el6.x86_64 (rhel6)
               php-common(x86-64) = 5.3.3-3.el6
           Available: php-common-5.3.3-3.el6_1.3.x86_64 (rhel6)
               php-common(x86-64) = 5.3.3-3.el6_1.3
           Available: php-common-5.3.3-3.el6_2.5.x86_64 (rhel6)
               php-common(x86-64) = 5.3.3-3.el6_2.5
           Available: php-common-5.3.3-3.el6_2.6.x86_64 (rhel6)
               php-common(x86-64) = 5.3.3-3.el6_2.6
           Available: php-common-5.3.3-3.el6_2.8.x86_64 (rhel6)
               php-common(x86-64) = 5.3.3-3.el6_2.8
           Available: php-common-5.3.3-14.el6_3.x86_64 (rhel6)
               php-common(x86-64) = 5.3.3-14.el6_3
           Available: php-common-5.3.3-22.el6.x86_64 (rhel6)
               php-common(x86-64) = 5.3.3-22.el6
           Available: php-common-5.3.3-23.el6_4.x86_64 (rhel6)
               php-common(x86-64) = 5.3.3-23.el6_4
           Available: php-common-5.3.3-26.el6.x86_64 (rhel6)
               php-common(x86-64) = 5.3.3-26.el6
Error: Package: php-bcmath-5.3.3-27.el6_5.x86_64 (openshift_node_cdn)
           Requires: php-common(x86-64) = 5.3.3-27.el6_5
           Removing: php-common-5.3.3-27.el6_5.x86_64 (@rhel6)
               php-common(x86-64) = 5.3.3-27.el6_5
           Updated By: php-common-5.3.3-36.el6.x86_64 (rhel_extra)
               php-common(x86-64) = 5.3.3-36.el6
           Available: php-common-5.3.2-6.el6.x86_64 (rhel6)
               php-common(x86-64) = 5.3.2-6.el6
           Available: php-common-5.3.2-6.el6_0.1.x86_64 (rhel6)
               php-common(x86-64) = 5.3.2-6.el6_0.1
           Available: php-common-5.3.3-3.el6.x86_64 (rhel6)
               php-common(x86-64) = 5.3.3-3.el6
           Available: php-common-5.3.3-3.el6_1.3.x86_64 (rhel6)
               php-common(x86-64) = 5.3.3-3.el6_1.3
           Available: php-common-5.3.3-3.el6_2.5.x86_64 (rhel6)
               php-common(x86-64) = 5.3.3-3.el6_2.5
           Available: php-common-5.3.3-3.el6_2.6.x86_64 (rhel6)
               php-common(x86-64) = 5.3.3-3.el6_2.6
           Available: php-common-5.3.3-3.el6_2.8.x86_64 (rhel6)
               php-common(x86-64) = 5.3.3-3.el6_2.8
           Available: php-common-5.3.3-14.el6_3.x86_64 (rhel6)
               php-common(x86-64) = 5.3.3-14.el6_3
           Available: php-common-5.3.3-22.el6.x86_64 (rhel6)
               php-common(x86-64) = 5.3.3-22.el6
           Available: php-common-5.3.3-23.el6_4.x86_64 (rhel6)
               php-common(x86-64) = 5.3.3-23.el6_4
           Available: php-common-5.3.3-26.el6.x86_64 (rhel6)
               php-common(x86-64) = 5.3.3-26.el6
Error: Package: php-fpm-5.3.3-27.el6_5.x86_64 (openshift_node_cdn)
           Requires: php-common(x86-64) = 5.3.3-27.el6_5
           Removing: php-common-5.3.3-27.el6_5.x86_64 (@rhel6)
               php-common(x86-64) = 5.3.3-27.el6_5
           Updated By: php-common-5.3.3-36.el6.x86_64 (rhel_extra)
               php-common(x86-64) = 5.3.3-36.el6
           Available: php-common-5.3.2-6.el6.x86_64 (rhel6)
               php-common(x86-64) = 5.3.2-6.el6
           Available: php-common-5.3.2-6.el6_0.1.x86_64 (rhel6)
               php-common(x86-64) = 5.3.2-6.el6_0.1
           Available: php-common-5.3.3-3.el6.x86_64 (rhel6)
               php-common(x86-64) = 5.3.3-3.el6
           Available: php-common-5.3.3-3.el6_1.3.x86_64 (rhel6)
               php-common(x86-64) = 5.3.3-3.el6_1.3
           Available: php-common-5.3.3-3.el6_2.5.x86_64 (rhel6)
               php-common(x86-64) = 5.3.3-3.el6_2.5
           Available: php-common-5.3.3-3.el6_2.6.x86_64 (rhel6)
               php-common(x86-64) = 5.3.3-3.el6_2.6
           Available: php-common-5.3.3-3.el6_2.8.x86_64 (rhel6)
               php-common(x86-64) = 5.3.3-3.el6_2.8
           Available: php-common-5.3.3-14.el6_3.x86_64 (rhel6)
               php-common(x86-64) = 5.3.3-14.el6_3
           Available: php-common-5.3.3-22.el6.x86_64 (rhel6)
               php-common(x86-64) = 5.3.3-22.el6
           Available: php-common-5.3.3-23.el6_4.x86_64 (rhel6)
               php-common(x86-64) = 5.3.3-23.el6_4
           Available: php-common-5.3.3-26.el6.x86_64 (rhel6)
               php-common(x86-64) = 5.3.3-26.el6
Error: Package: php-mbstring-5.3.3-27.el6_5.x86_64 (openshift_node_extra)
           Requires: php-common(x86-64) = 5.3.3-27.el6_5
           Removing: php-common-5.3.3-27.el6_5.x86_64 (@rhel6)
               php-common(x86-64) = 5.3.3-27.el6_5
           Updated By: php-common-5.3.3-36.el6.x86_64 (rhel_extra)
               php-common(x86-64) = 5.3.3-36.el6
           Available: php-common-5.3.2-6.el6.x86_64 (rhel6)
               php-common(x86-64) = 5.3.2-6.el6
           Available: php-common-5.3.2-6.el6_0.1.x86_64 (rhel6)
               php-common(x86-64) = 5.3.2-6.el6_0.1
           Available: php-common-5.3.3-3.el6.x86_64 (rhel6)
               php-common(x86-64) = 5.3.3-3.el6
           Available: php-common-5.3.3-3.el6_1.3.x86_64 (rhel6)
               php-common(x86-64) = 5.3.3-3.el6_1.3
           Available: php-common-5.3.3-3.el6_2.5.x86_64 (rhel6)
               php-common(x86-64) = 5.3.3-3.el6_2.5
           Available: php-common-5.3.3-3.el6_2.6.x86_64 (rhel6)
               php-common(x86-64) = 5.3.3-3.el6_2.6
           Available: php-common-5.3.3-3.el6_2.8.x86_64 (rhel6)
               php-common(x86-64) = 5.3.3-3.el6_2.8
           Available: php-common-5.3.3-14.el6_3.x86_64 (rhel6)
               php-common(x86-64) = 5.3.3-14.el6_3
           Available: php-common-5.3.3-22.el6.x86_64 (rhel6)
               php-common(x86-64) = 5.3.3-22.el6
           Available: php-common-5.3.3-23.el6_4.x86_64 (rhel6)
               php-common(x86-64) = 5.3.3-23.el6_4
           Available: php-common-5.3.3-26.el6.x86_64 (rhel6)
               php-common(x86-64) = 5.3.3-26.el6
Error: Package: php-process-5.3.3-27.el6_5.x86_64 (openshift_node_extra)
           Requires: php-common(x86-64) = 5.3.3-27.el6_5
           Removing: php-common-5.3.3-27.el6_5.x86_64 (@rhel6)
               php-common(x86-64) = 5.3.3-27.el6_5
           Updated By: php-common-5.3.3-36.el6.x86_64 (rhel_extra)
               php-common(x86-64) = 5.3.3-36.el6
           Available: php-common-5.3.2-6.el6.x86_64 (rhel6)
               php-common(x86-64) = 5.3.2-6.el6
           Available: php-common-5.3.2-6.el6_0.1.x86_64 (rhel6)
               php-common(x86-64) = 5.3.2-6.el6_0.1
           Available: php-common-5.3.3-3.el6.x86_64 (rhel6)
               php-common(x86-64) = 5.3.3-3.el6
           Available: php-common-5.3.3-3.el6_1.3.x86_64 (rhel6)
               php-common(x86-64) = 5.3.3-3.el6_1.3
           Available: php-common-5.3.3-3.el6_2.5.x86_64 (rhel6)
               php-common(x86-64) = 5.3.3-3.el6_2.5
           Available: php-common-5.3.3-3.el6_2.6.x86_64 (rhel6)
               php-common(x86-64) = 5.3.3-3.el6_2.6
           Available: php-common-5.3.3-3.el6_2.8.x86_64 (rhel6)
               php-common(x86-64) = 5.3.3-3.el6_2.8
           Available: php-common-5.3.3-14.el6_3.x86_64 (rhel6)
               php-common(x86-64) = 5.3.3-14.el6_3
           Available: php-common-5.3.3-22.el6.x86_64 (rhel6)
               php-common(x86-64) = 5.3.3-22.el6
           Available: php-common-5.3.3-23.el6_4.x86_64 (rhel6)
               php-common(x86-64) = 5.3.3-23.el6_4
           Available: php-common-5.3.3-26.el6.x86_64 (rhel6)
               php-common(x86-64) = 5.3.3-26.el6
Error: Package: php-imap-5.3.3-27.el6_5.x86_64 (openshift_node_cdn)
           Requires: php-common(x86-64) = 5.3.3-27.el6_5
           Removing: php-common-5.3.3-27.el6_5.x86_64 (@rhel6)
               php-common(x86-64) = 5.3.3-27.el6_5
           Updated By: php-common-5.3.3-36.el6.x86_64 (rhel_extra)
               php-common(x86-64) = 5.3.3-36.el6
           Available: php-common-5.3.2-6.el6.x86_64 (rhel6)
               php-common(x86-64) = 5.3.2-6.el6
           Available: php-common-5.3.2-6.el6_0.1.x86_64 (rhel6)
               php-common(x86-64) = 5.3.2-6.el6_0.1
           Available: php-common-5.3.3-3.el6.x86_64 (rhel6)
               php-common(x86-64) = 5.3.3-3.el6
           Available: php-common-5.3.3-3.el6_1.3.x86_64 (rhel6)
               php-common(x86-64) = 5.3.3-3.el6_1.3
           Available: php-common-5.3.3-3.el6_2.5.x86_64 (rhel6)
               php-common(x86-64) = 5.3.3-3.el6_2.5
           Available: php-common-5.3.3-3.el6_2.6.x86_64 (rhel6)
               php-common(x86-64) = 5.3.3-3.el6_2.6
           Available: php-common-5.3.3-3.el6_2.8.x86_64 (rhel6)
               php-common(x86-64) = 5.3.3-3.el6_2.8
           Available: php-common-5.3.3-14.el6_3.x86_64 (rhel6)
               php-common(x86-64) = 5.3.3-14.el6_3
           Available: php-common-5.3.3-22.el6.x86_64 (rhel6)
               php-common(x86-64) = 5.3.3-22.el6
           Available: php-common-5.3.3-23.el6_4.x86_64 (rhel6)
               php-common(x86-64) = 5.3.3-23.el6_4
           Available: php-common-5.3.3-26.el6.x86_64 (rhel6)
               php-common(x86-64) = 5.3.3-26.el6
Error: Package: php-devel-5.3.3-27.el6_5.x86_64 (openshift_node_cdn)
           Requires: php(x86-64) = 5.3.3-27.el6_5
           Removing: php-5.3.3-27.el6_5.x86_64 (@rhel6)
               php(x86-64) = 5.3.3-27.el6_5
           Updated By: php-5.3.3-36.el6.x86_64 (rhel_extra)
               php(x86-64) = 5.3.3-36.el6
           Available: php-5.3.2-6.el6.x86_64 (rhel6)
               php(x86-64) = 5.3.2-6.el6
           Available: php-5.3.2-6.el6_0.1.x86_64 (rhel6)
               php(x86-64) = 5.3.2-6.el6_0.1
           Available: php-5.3.3-3.el6.x86_64 (rhel6)
               php(x86-64) = 5.3.3-3.el6
           Available: php-5.3.3-3.el6_1.3.x86_64 (rhel6)
               php(x86-64) = 5.3.3-3.el6_1.3
           Available: php-5.3.3-3.el6_2.5.x86_64 (rhel6)
               php(x86-64) = 5.3.3-3.el6_2.5
           Available: php-5.3.3-3.el6_2.6.x86_64 (rhel6)
               php(x86-64) = 5.3.3-3.el6_2.6
           Available: php-5.3.3-3.el6_2.8.x86_64 (rhel6)
               php(x86-64) = 5.3.3-3.el6_2.8
           Available: php-5.3.3-14.el6_3.x86_64 (rhel6)
               php(x86-64) = 5.3.3-14.el6_3
           Available: php-5.3.3-22.el6.x86_64 (rhel6)
               php(x86-64) = 5.3.3-22.el6
           Available: php-5.3.3-23.el6_4.x86_64 (rhel6)
               php(x86-64) = 5.3.3-23.el6_4
           Available: php-5.3.3-26.el6.x86_64 (rhel6)
               php(x86-64) = 5.3.3-26.el6
Error: Package: php-devel-5.3.3-27.el6_5.x86_64 (openshift_node_extra)
           Requires: php(x86-64) = 5.3.3-27.el6_5
           Removing: php-5.3.3-27.el6_5.x86_64 (@rhel6)
               php(x86-64) = 5.3.3-27.el6_5
           Updated By: php-5.3.3-36.el6.x86_64 (rhel_extra)
               php(x86-64) = 5.3.3-36.el6
           Available: php-5.3.2-6.el6.x86_64 (rhel6)
               php(x86-64) = 5.3.2-6.el6
           Available: php-5.3.2-6.el6_0.1.x86_64 (rhel6)
               php(x86-64) = 5.3.2-6.el6_0.1
           Available: php-5.3.3-3.el6.x86_64 (rhel6)
               php(x86-64) = 5.3.3-3.el6
           Available: php-5.3.3-3.el6_1.3.x86_64 (rhel6)
               php(x86-64) = 5.3.3-3.el6_1.3
           Available: php-5.3.3-3.el6_2.5.x86_64 (rhel6)
               php(x86-64) = 5.3.3-3.el6_2.5
           Available: php-5.3.3-3.el6_2.6.x86_64 (rhel6)
               php(x86-64) = 5.3.3-3.el6_2.6
           Available: php-5.3.3-3.el6_2.8.x86_64 (rhel6)
               php(x86-64) = 5.3.3-3.el6_2.8
           Available: php-5.3.3-14.el6_3.x86_64 (rhel6)
               php(x86-64) = 5.3.3-14.el6_3
           Available: php-5.3.3-22.el6.x86_64 (rhel6)
               php(x86-64) = 5.3.3-22.el6
           Available: php-5.3.3-23.el6_4.x86_64 (rhel6)
               php(x86-64) = 5.3.3-23.el6_4
           Available: php-5.3.3-26.el6.x86_64 (rhel6)
               php(x86-64) = 5.3.3-26.el6
Error: Package: php-bcmath-5.3.3-27.el6_5.x86_64 (openshift_node_extra)
           Requires: php-common(x86-64) = 5.3.3-27.el6_5
           Removing: php-common-5.3.3-27.el6_5.x86_64 (@rhel6)
               php-common(x86-64) = 5.3.3-27.el6_5
           Updated By: php-common-5.3.3-36.el6.x86_64 (rhel_extra)
               php-common(x86-64) = 5.3.3-36.el6
           Available: php-common-5.3.2-6.el6.x86_64 (rhel6)
               php-common(x86-64) = 5.3.2-6.el6
           Available: php-common-5.3.2-6.el6_0.1.x86_64 (rhel6)
               php-common(x86-64) = 5.3.2-6.el6_0.1
           Available: php-common-5.3.3-3.el6.x86_64 (rhel6)
               php-common(x86-64) = 5.3.3-3.el6
           Available: php-common-5.3.3-3.el6_1.3.x86_64 (rhel6)
               php-common(x86-64) = 5.3.3-3.el6_1.3
           Available: php-common-5.3.3-3.el6_2.5.x86_64 (rhel6)
               php-common(x86-64) = 5.3.3-3.el6_2.5
           Available: php-common-5.3.3-3.el6_2.6.x86_64 (rhel6)
               php-common(x86-64) = 5.3.3-3.el6_2.6
           Available: php-common-5.3.3-3.el6_2.8.x86_64 (rhel6)
               php-common(x86-64) = 5.3.3-3.el6_2.8
           Available: php-common-5.3.3-14.el6_3.x86_64 (rhel6)
               php-common(x86-64) = 5.3.3-14.el6_3
           Available: php-common-5.3.3-22.el6.x86_64 (rhel6)
               php-common(x86-64) = 5.3.3-22.el6
           Available: php-common-5.3.3-23.el6_4.x86_64 (rhel6)
               php-common(x86-64) = 5.3.3-23.el6_4
           Available: php-common-5.3.3-26.el6.x86_64 (rhel6)
               php-common(x86-64) = 5.3.3-26.el6
Error: Package: php-fpm-5.3.3-27.el6_5.x86_64 (openshift_node_extra)
           Requires: php-common(x86-64) = 5.3.3-27.el6_5
           Removing: php-common-5.3.3-27.el6_5.x86_64 (@rhel6)
               php-common(x86-64) = 5.3.3-27.el6_5
           Updated By: php-common-5.3.3-36.el6.x86_64 (rhel_extra)
               php-common(x86-64) = 5.3.3-36.el6
           Available: php-common-5.3.2-6.el6.x86_64 (rhel6)
               php-common(x86-64) = 5.3.2-6.el6
           Available: php-common-5.3.2-6.el6_0.1.x86_64 (rhel6)
               php-common(x86-64) = 5.3.2-6.el6_0.1
           Available: php-common-5.3.3-3.el6.x86_64 (rhel6)
               php-common(x86-64) = 5.3.3-3.el6
           Available: php-common-5.3.3-3.el6_1.3.x86_64 (rhel6)
               php-common(x86-64) = 5.3.3-3.el6_1.3
           Available: php-common-5.3.3-3.el6_2.5.x86_64 (rhel6)
               php-common(x86-64) = 5.3.3-3.el6_2.5
           Available: php-common-5.3.3-3.el6_2.6.x86_64 (rhel6)
               php-common(x86-64) = 5.3.3-3.el6_2.6
           Available: php-common-5.3.3-3.el6_2.8.x86_64 (rhel6)
               php-common(x86-64) = 5.3.3-3.el6_2.8
           Available: php-common-5.3.3-14.el6_3.x86_64 (rhel6)
               php-common(x86-64) = 5.3.3-14.el6_3
           Available: php-common-5.3.3-22.el6.x86_64 (rhel6)
               php-common(x86-64) = 5.3.3-22.el6
           Available: php-common-5.3.3-23.el6_4.x86_64 (rhel6)
               php-common(x86-64) = 5.3.3-23.el6_4
           Available: php-common-5.3.3-26.el6.x86_64 (rhel6)
               php-common(x86-64) = 5.3.3-26.el6
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest


Expected results:
Install successfully

Additional info:

Comment 1 Brenton Leanhardt 2014-08-05 12:34:10 UTC
We're going to have to create a RHEL 6.6 advisory to bucket all these sorts of dependencies.  It will have to be a separate puddle configuration so we don't complicate our normal maintenance testing.

Comment 2 Luke Meyer 2014-08-05 13:29:46 UTC

*** This bug has been marked as a duplicate of bug 1126766 ***

Comment 3 Ma xiaoqiang 2014-08-06 02:17:39 UTC
This bug trace the different package, and only exists on ose2.1. Only if installed the optional package, we can reproduce it. so shouldn't be marked as a duplicate.

Comment 7 errata-xmlrpc 2016-05-12 16:36:31 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1065


Note You need to log in before you can comment on or make changes to this bug.