Bug 1126774 - Operating System description is "Other OS" instead of RHEL7 / RHEL7 is not recognized by RHEV
Summary: Operating System description is "Other OS" instead of RHEL7 / RHEL7 is not re...
Keywords:
Status: CLOSED DUPLICATE of bug 1116122
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: rhel-guest-image
Version: 7.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: rc
: 7.0
Assignee: Fabian Deutsch
QA Contact: Virtualization Bugs
URL:
Whiteboard: node
Depends On: 1111522 1116122
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-05 08:59 UTC by Fabian Deutsch
Modified: 2015-03-18 09:10 UTC (History)
21 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Due to a bug in rhel_guest_image code, the value of the Operating System field in the Red Hat Enterprise Virtualization Manager interface was previously incorrectly displayed as "Red Hat Enterprise Linux 6.x" after a Red Hat Enterprise Linux 7 guest was uploaded and a template imported. This update fixes this bug and the Operating System field now shows the correct guest information.
Clone Of: 1116122
Environment:
Last Closed: 2014-09-09 18:50:08 UTC


Attachments (Terms of Use)
rhevm_other_os_problem (40.58 KB, image/png)
2014-08-21 02:50 UTC, yuliu
no flags Details
rhevm_other_os_problem2 (64.47 KB, image/png)
2014-08-21 02:51 UTC, yuliu
no flags Details

Comment 1 Fabian Deutsch 2014-08-05 09:00:38 UTC
The 7.0 guest image uses the key/description RHEL7x64 in the ova file, it looks like this key is unknown to RHEV-M:

$ egrep -rn RHEL.x64
frontend/webadmin/modules/uicompat/src/main/resources/org/ovirt/engine/ui/uicompat/Enums.properties:70:VmOsType___RHEL6x64=Red Hat Enterprise Linux 6.x x64
frontend/webadmin/modules/uicompat/src/main/resources/org/ovirt/engine/ui/uicompat/Enums.properties:72:VmOsType___RHEL5x64=Red Hat Enterprise Linux 5.x x64
frontend/webadmin/modules/uicompat/src/main/resources/org/ovirt/engine/ui/uicompat/Enums.properties:74:VmOsType___RHEL4x64=Red Hat Enterprise Linux 4.x x64
frontend/webadmin/modules/uicompat/src/main/resources/org/ovirt/engine/ui/uicompat/Enums.properties:76:VmOsType___RHEL3x64=Red Hat Enterprise Linux 3.x x64
packaging/conf/osinfo-defaults.properties:108:# RHEL4x64(14, OsType.Linux, true),
packaging/conf/osinfo-defaults.properties:354:backwardCompatibility.RHEL3x64 = 15
packaging/conf/osinfo-defaults.properties:356:backwardCompatibility.RHEL4x64 = 14
packaging/conf/osinfo-defaults.properties:358:backwardCompatibility.RHEL5x64 = 13
packaging/conf/osinfo-defaults.properties:360:backwardCompatibility.RHEL6x64 = 19
backend/manager/modules/bll/src/test/java/org/ovirt/engine/core/bll/HotPlugDiskToVmCommandTest.java:188:        when(osRepository.getOsName(15)).thenReturn("RHEL3x64");
$

Comment 2 Fabian Deutsch 2014-08-06 08:20:20 UTC
This also has the affect that some things (i.e. setting the root password) do not work.

Comment 3 Fabian Deutsch 2014-08-06 08:24:22 UTC
I'm raising the priority because if the user does not choose the correct operating system family manually, then setting the root password will fail.

Comment 4 Michal Skrivanek 2014-08-07 11:42:23 UTC
Fabian,
RHEL 7 has been added in oVirt 3.4.1 bug 1083065 as
os.rhel_7x64.id.value = 24
os.rhel_7x64.name.value = Red Hat Enterprise Linux 7.x x64

What's missing?

Comment 5 Fabian Deutsch 2014-08-07 11:48:30 UTC
Hey Michal, the RHEL guest images 7.0 OVA is using the description "RHEL7x64", that this did not translate to the correct description in RHEV-M.

Michal, can you tell if that "description" field in the OVA is used to determin the guest OS - or if a different field of the OVA is used?

Yu Liu, can you please provide the RHEV-M version you are using?

Comment 6 Michal Skrivanek 2014-08-07 15:53:24 UTC
(In reply to Fabian Deutsch from comment #5)
> Michal, can you tell if that "description" field in the OVA is used to
> determin the guest OS - or if a different field of the OVA is used?

I was hoping it's the actual ID value…but I may be wrong
How does the OVA look like?

Comment 7 yuliu 2014-08-08 01:38:59 UTC
(In reply to Fabian Deutsch from comment #5)
> Hey Michal, the RHEL guest images 7.0 OVA is using the description
> "RHEL7x64", that this did not translate to the correct description in RHEV-M.
> 
> Michal, can you tell if that "description" field in the OVA is used to
> determin the guest OS - or if a different field of the OVA is used?
> 
> Yu Liu, can you please provide the RHEV-M version you are using?

Hi fabiand, I tried it on two version:
rhevm-setup-plugin-ovirt-engine-3.4.1-0.30.el6ev.noarch
rhevm-setup-plugin-ovirt-engine-3.4.0-0.16.rc.el6ev.noarch

Both using 3.4

Comment 8 Michal Skrivanek 2014-08-13 11:37:16 UTC
the second one is 3.4.0 and as I said in comment #4 RHEL 7 was added in 3.4.1.

I also still need an answer to comment #6

Comment 9 Fabian Deutsch 2014-08-14 15:31:08 UTC
Michal, what do you actualyl need from the OVA?

Comment 10 Michal Skrivanek 2014-08-15 07:08:07 UTC
I don't know what's in the OVA you mentioned. Can you post the link or copy the relevant section? Does it have the ID there?

what's the original issue here anyway? https://bugzilla.redhat.com/show_bug.cgi?id=1111522#c0 ? It's not valid if the RHEV-M is 3.4.0 as RHEL 7 was *not* supported there, only since 3.4.1. Id and/or name need to match comment #4

Comment 11 yuliu 2014-08-21 02:50:35 UTC
Created attachment 928992 [details]
rhevm_other_os_problem

Comment 12 yuliu 2014-08-21 02:51:18 UTC
Created attachment 928993 [details]
rhevm_other_os_problem2

Comment 13 yuliu 2014-08-21 02:58:35 UTC
(In reply to Michal Skrivanek from comment #10)
> I don't know what's in the OVA you mentioned. Can you post the link or copy
> the relevant section? Does it have the ID there?
> 
> what's the original issue here anyway?
> https://bugzilla.redhat.com/show_bug.cgi?id=1111522#c0 ? It's not valid if
> the RHEV-M is 3.4.0 as RHEL 7 was *not* supported there, only since 3.4.1.
> Id and/or name need to match comment #4

I believe that the "OVA" what Fabiand said is acutally "OVF", it's located here after install rhel-guest-image rpm:
#pwd
/usr/share/rhel-guest-image-$x/$version/master/vms/$version

And the detail of describing operation system is below:

<Section ovf:id="f9350d95-31b7-41d4-87ac-1526fa1435ab" ovf:required="false" xsi:type="ovf:OperatingSystemSection_Type">
      <Info>Guest OS</Info>
      <Description>RHEL7x64</Description>
</Section>

By default, the Operating System supposed to be 'Red Hat Enterprise Linux 7.x x64' but in fact it's 'Other OS' instead.

Still confused if you're, please check these two pictures I attacked to the top.

Comment 14 Michal Skrivanek 2014-08-21 14:03:00 UTC
(In reply to yuliu from comment #13)
great. thanks.
just to doublecheck…so you took this ovf and tried to import it into 3.4.1 environment and the bug still reproduces? Please confirm 3.4.1 vs 3.4.0

Comment 15 yuliu 2014-08-22 01:20:57 UTC
(In reply to Michal Skrivanek from comment #14)
> (In reply to yuliu from comment #13)
> great. thanks.
> just to doublecheck…so you took this ovf and tried to import it into 3.4.1
> environment and the bug still reproduces? Please confirm 3.4.1 vs 3.4.0

Yes, I can reproduce this bug in 3.4.1

Comment 16 Omer Frenkel 2014-09-01 16:08:04 UTC
engine expects to match the exact string (case sensitive) means: rhel_7x64 
if there is no match, "other" is used.

what generated this string?

Comment 17 Fabian Deutsch 2014-09-02 10:52:15 UTC
(In reply to Omer Frenkel from comment #16)
> engine expects to match the exact string (case sensitive) means: rhel_7x64 
> if there is no match, "other" is used.
> 
> what generated this string?

A small script we use to create ovf.
So it's easy to change.

But I also plan to switch over to brews/kojis capabilities to build the ova, I'm not sure what brew is setting as a description.

Comment 18 Fabian Deutsch 2014-09-02 14:42:46 UTC
What is confusing me a bit is, that the RHEL 6 images are using RHEL6x64, and we simply just changed the major version (so it becomes RHEL7x64).

I wonder why the RHEL6 images are identified correctly but not the RHEL 7 images.

I'm open to change the description string to match with the string in RHEVM

Comment 19 Omer Frenkel 2014-09-03 15:37:50 UTC
Right, this is the "old" os names (== before we introduced the OsInfo which is configuration on the guest os level) and it works because we need to keep backward compatibility.

if you look in share/ovirt-engine/conf/osinfo-defaults.properties
you can see the backward compatibility mapping for old naming

and new OS like rhel7 are not added there anymore.
so the right naming is rhel_Zx64 going fwd

Comment 20 Fabian Deutsch 2014-09-03 15:59:05 UTC
Thanks for that informative answer. I will then adjust the description for the next update. That way the image should turn up correctly.

Comment 21 Ryan Barry 2014-09-09 18:50:08 UTC

*** This bug has been marked as a duplicate of bug 1116122 ***


Note You need to log in before you can comment on or make changes to this bug.