Bug 112705 - (XFSPROGS) Unable to install xfsprogs-devel due to bad spec value
Summary: (XFSPROGS) Unable to install xfsprogs-devel due to bad spec value
Status: CLOSED UPSTREAM
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: xfsprogs   
(Show other bugs)
Version: 1.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeff Garzik
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On: 66513
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-12-29 09:28 UTC by Peter Robinson
Modified: 2013-07-03 02:17 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-09 09:38:18 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Peter Robinson 2003-12-29 09:28:55 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1)
Gecko/20031114

Description of problem:
When trying to install the xfsprogs packages the installation fails
due to bad dependancy for xfsprogs-devel as below. I believe the
variable should be %{version} not eversion as stated (and is hence
probably just a typo in the .spec file)

[root@neo up2date]# rpm -Uvh xfsprogs*
error: Failed dependencies:
        xfsprogs = %{eversion} is needed by xfsprogs-devel-2.6.0-1


Version-Release number of selected component (if applicable):
xfsprogs-2.6.0-1

How reproducible:
Always

Steps to Reproduce:
1. Try to install xfsprogs programs
2. Fails with dependancy problem
3. Can install with a --nodeps with no problems
    

Actual Results:  Fails with depenancy problems

Expected Results:  Should install RPMS

Additional info:

Can be worked around with a rpm -ivh --nodeps xfsprogs*


Note You need to log in before you can comment on or make changes to this bug.