Bug 1127105 - Install with a file name failed with a backtrace : "_hawkey.Exception: Goal operation failed"
Summary: Install with a file name failed with a backtrace : "_hawkey.Exception: Goal o...
Keywords:
Status: CLOSED DUPLICATE of bug 1127206
Alias: None
Product: Fedora
Classification: Fedora
Component: dnf
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Packaging Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-06 07:36 UTC by Clément DAVID
Modified: 2014-08-06 12:33 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-06 12:33:42 UTC


Attachments (Terms of Use)

Description Clément DAVID 2014-08-06 07:36:06 UTC
Version-Release number of selected component (if applicable):
$ dnf --version
0.5.5
  Installed: dnf-0:0.5.5-1.fc22.noarch at 2014-08-04 11:51
  Built    : Fedora Project at 2014-07-28 14:15

  Installed: rpm-0:4.11.90-0.git12844.5.fc21.x86_64 at 2014-07-23 16:53
  Built    : Fedora Project at 2014-07-03 10:55


How reproducible:
always

Steps to Reproduce:
1.$ sudo dnf install /usr/lib64/libstdc++.a

Actual results:

Traceback (most recent call last):
  File "/bin/dnf", line 36, in <module>
    main.user_main(sys.argv[1:], exit_code=True)
  File "/usr/lib/python2.7/site-packages/dnf/cli/main.py", line 200, in user_main
    errcode = main(args)
  File "/usr/lib/python2.7/site-packages/dnf/cli/main.py", line 83, in main
    return _main(base, args)
  File "/usr/lib/python2.7/site-packages/dnf/cli/main.py", line 133, in _main
    cli.run()
  File "/usr/lib/python2.7/site-packages/dnf/cli/cli.py", line 1053, in run
    return self.command.run(self.base.extcmds)
  File "/usr/lib/python2.7/site-packages/dnf/cli/commands/install.py", line 97, in run
    self.base.install(pkg_spec)
  File "/usr/lib/python2.7/site-packages/dnf/base.py", line 1261, in install
    self._goal.install(select=sltr)
  File "/usr/lib64/python2.7/site-packages/hawkey/__init__.py", line 160, in tweaked_fn
    return fn(self, *args, **kwargs)
  File "/usr/lib64/python2.7/site-packages/hawkey/__init__.py", line 186, in install
    super(Goal, self).install(*args, **kwargs)
_hawkey.Exception: Goal operation failed.

Expected results:

as yum display :
"No package /usr/lib64/libstdc++.a available."

Additional info:

Comment 1 Honza Silhan 2014-08-06 12:33:42 UTC
Hi, thanks for the report.

*** This bug has been marked as a duplicate of bug 1127206 ***


Note You need to log in before you can comment on or make changes to this bug.