Bug 1127206 - [abrt] dnf: __init__.py:186:install:Exception: Goal operation failed.
[abrt] dnf: __init__.py:186:install:Exception: Goal operation failed.
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
21
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Honza Silhan
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
abrt_hash:c048995e2d86b190990f144d865...
:
: 1127105 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2014-08-06 07:43 EDT by Dan Callaghan
Modified: 2014-08-12 03:19 EDT (History)
7 users (show)

See Also:
Fixed In Version: dnf-0.6.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-08-12 03:17:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (1.26 KB, text/plain)
2014-08-06 07:43 EDT, Dan Callaghan
no flags Details
File: environ (3.22 KB, text/plain)
2014-08-06 07:43 EDT, Dan Callaghan
no flags Details

  None (edit)
Description Dan Callaghan 2014-08-06 07:43:44 EDT
Description of problem:
dnf install /usr/bin/jar

Version-Release number of selected component:
dnf-0.5.5-1.fc21

Additional info:
reporter:       libreport-2.2.3
cmdline:        /usr/bin/python -OO /bin/dnf install /usr/bin/jar
dso_list:       python-hawkey-0.4.19-1.fc21.x86_64
executable:     /bin/dnf
kernel:         3.16.0-0.rc7.git4.1.fc21.x86_64
runlevel:       N 5
type:           Python
uid:            0

Truncated backtrace:
__init__.py:186:install:Exception: Goal operation failed.

Traceback (most recent call last):
  File "/bin/dnf", line 36, in <module>
    main.user_main(sys.argv[1:], exit_code=True)
  File "/usr/lib/python2.7/site-packages/dnf/cli/main.py", line 200, in user_main
    errcode = main(args)
  File "/usr/lib/python2.7/site-packages/dnf/cli/main.py", line 83, in main
    return _main(base, args)
  File "/usr/lib/python2.7/site-packages/dnf/cli/main.py", line 133, in _main
    cli.run()
  File "/usr/lib/python2.7/site-packages/dnf/cli/cli.py", line 1053, in run
    return self.command.run(self.base.extcmds)
  File "/usr/lib/python2.7/site-packages/dnf/cli/commands/install.py", line 97, in run
    self.base.install(pkg_spec)
  File "/usr/lib/python2.7/site-packages/dnf/base.py", line 1261, in install
    self._goal.install(select=sltr)
  File "/usr/lib64/python2.7/site-packages/hawkey/__init__.py", line 160, in tweaked_fn
    return fn(self, *args, **kwargs)
  File "/usr/lib64/python2.7/site-packages/hawkey/__init__.py", line 186, in install
    super(Goal, self).install(*args, **kwargs)
Exception: Goal operation failed.

Local variables in innermost frame:
self: <dnf.goal.Goal object at 0x7f5d32c4ab40>
args: ()
kwargs: {'select': <dnf.selector.Selector object at 0x7f5d32c5a910>}
Comment 1 Dan Callaghan 2014-08-06 07:43:48 EDT
Created attachment 924457 [details]
File: backtrace
Comment 2 Dan Callaghan 2014-08-06 07:43:49 EDT
Created attachment 924458 [details]
File: environ
Comment 3 Honza Silhan 2014-08-06 08:33:42 EDT
*** Bug 1127105 has been marked as a duplicate of this bug. ***
Comment 4 Honza Silhan 2014-08-06 08:37:32 EDT
Hi, thanks for the report. I will take a look. It's probably due to recent changes I made to install <file> feature.

Note You need to log in before you can comment on or make changes to this bug.