Bug 1127294 - Live Merge: Resolve unknown merge status in vdsm after host crash
Summary: Live Merge: Resolve unknown merge status in vdsm after host crash
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: oVirt
Classification: Retired
Component: vdsm
Version: 3.5
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: 3.5.0
Assignee: Adam Litke
QA Contact: Kevin Alon Goldblatt
URL:
Whiteboard: storage
Depends On:
Blocks: 1073943
TreeView+ depends on / blocked
 
Reported: 2014-08-06 14:39 UTC by Adam Litke
Modified: 2016-02-10 19:43 UTC (History)
10 users (show)

Fixed In Version: v4.16.4
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-10-17 12:42:19 UTC
oVirt Team: Storage


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 31267 master ABANDONED Live Merge: Resolve unknown merge status in vdsm after host crash Never
oVirt gerrit 32321 ovirt-3.5 MERGED qemuimg: Handle new output format Never
oVirt gerrit 32324 ovirt-3.5 MERGED Live Merge: Mark active layer ILLEGAL before pivoting Never
oVirt gerrit 32328 ovirt-3.5 MERGED Live Merge: add reconcileVolumeChain verb Never

Description Adam Litke 2014-08-06 14:39:58 UTC
Description of problem: When a host crashes during a live merge operation resulting in the VM crashing, we need to take some special steps in vdsm to ensure that we can recover using shared storage only.  This involves two changes:

1. For active layer merges, mark the leaf volume as ILLEGAL before pivoting.  This allows engine to determine that this leaf has been merged and can be discarded.

2. Allow a live merge to be resubmitted on a new host using blank volume uuids.  This will tell vdsm to skip the libvirt part of the merge but to rerun synchronization operations.

How reproducible: Always


Steps to Reproduce:
1. Start live merge operation
2. Panic host in the middle of the operation
3. Reboot host
4. Re-run VM

Actual results: Engine cannot re-run the vm because the previous live merge operation status cannot be determined.


Expected results: Engine re-runs the VM and the metadata is properly synchronized to the results of the initial live merge operation.

Comment 1 Sandro Bonazzola 2014-10-17 12:42:19 UTC
oVirt 3.5 has been released and should include the fix for this issue.


Note You need to log in before you can comment on or make changes to this bug.