Bug 1127307 - Installer fails if Satellite hostname doesn't have a TLD at the end of the domain
Summary: Installer fails if Satellite hostname doesn't have a TLD at the end of the do...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Installer
Version: 6.0.4
Hardware: Unspecified
OS: Unspecified
high
high vote
Target Milestone: Unspecified
Assignee: Mike McCune
QA Contact: Katello QA List
URL:
Whiteboard:
Depends On:
Blocks: sat61-release-notes
TreeView+ depends on / blocked
 
Reported: 2014-08-06 15:17 UTC by Mike McCune
Modified: 2016-07-29 13:50 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-29 13:50:29 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Foreman Issue Tracker 4675 None None None Never
Foreman Issue Tracker 15216 None None None 2016-05-27 16:52:56 UTC

Description Mike McCune 2014-08-06 15:17:16 UTC
Users with domains containing hyphens are unable to install Satellite 6, they get errors during installation:

[root@sat6 ~]# katello-installer
 /Stage[main]/Foreman_proxy::Register/Foreman_smartproxy[sat6.test.example-domain]: Could not evaluate: 500 Internal Server Error
Installing             Done            [100%] 

We need to determine why Satellite 6 can't be installed on systems with a domain including a hyphen and support this use case.

Steps to reproduce:

1) Setup a system who's domain name resolves to something with a hyphen:

sat6test.example-domain.com

2) Attempt to run katello-installer

3) note errors

Comment 1 RHEL Product and Program Management 2014-08-06 15:43:51 UTC
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.

Comment 4 Mike McCune 2014-08-12 22:40:28 UTC
Clarification:

It will only fail if the domain is missing a TLD:

FAIL: hostname.domain-example

PASS: hostname.domain-example.com

Comment 5 Mike McCune 2014-08-12 22:45:30 UTC
This is:

http://projects.theforeman.org/issues/4675

Comment 6 Mike McCune 2014-08-12 22:51:21 UTC
WORKAROUND, specify a valid email address in the installer with a TLD

# katello-installer --foreman-admin-email=root@localhost.example.com

Comment 8 David O'Brien 2015-06-17 05:14:20 UTC
Added to beta release notes. Not brewed yet.

Comment 12 Bryan Kearney 2016-05-27 16:52:54 UTC
Created redmine issue http://projects.theforeman.org/issues/15216 from this bug


Note You need to log in before you can comment on or make changes to this bug.