Bug 1127552 - Guest display turns dark after switching to very high resolution
Summary: Guest display turns dark after switching to very high resolution
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: xorg-x11-drv-qxl
Version: 7.1
Hardware: Unspecified
OS: Unspecified
medium
unspecified
Target Milestone: rc
: ---
Assignee: Default Assignee for SPICE Bugs
QA Contact: Desktop QE
URL:
Whiteboard:
: 1152593 (view as bug list)
Depends On: 1076728
Blocks: 1158233
TreeView+ depends on / blocked
 
Reported: 2014-08-07 06:20 UTC by zhoujunqin
Modified: 2015-03-05 13:33 UTC (History)
11 users (show)

Fixed In Version: xorg-x11-drv-qxl-0.1.1-12.el7
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1158233 (view as bug list)
Environment:
Last Closed: 2015-03-05 13:33:14 UTC


Attachments (Terms of Use)
Xorg.0.log for rhel6 guest (63.49 KB, text/plain)
2014-08-07 06:21 UTC, zhoujunqin
no flags Details
spice debug info for rhel6 guest (125.70 KB, text/plain)
2014-08-07 06:22 UTC, zhoujunqin
no flags Details
qemu.log for guest kvm-rhel7.0-qcow2 (4.89 KB, text/plain)
2014-12-18 05:11 UTC, zhoujunqin
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:0578 normal SHIPPED_LIVE xorg-x11-drv-qxl bug fix update 2015-03-05 17:07:22 UTC

Description zhoujunqin 2014-08-07 06:20:15 UTC
Description of problem:
Since when guest is in fullscreen mode, if (and only if) the mouse pointer is hovering above the menu at the top of the screen, it is now possible to zoom in/out with keyboard shortcuts. 
When i use shortcuts ctrl+[-] very frequently, that means repeat ctrl+- several times quickly, the fullscreen will turn to dark, and  showing "Wait for display 1....".

I'm not sure about component, so please feel free to change the right component.

Version-Release number of selected component (if applicable):

virt-viewer-0.6.0-3.el7.x86_64
xorg-x11-drv-qxl-0.1.1-9.el7.x86_64
kernel-3.10.0-142.el7.x86_64
spice-gtk3-devel-0.22-1.el7.x86_64
spice-xpi-2.8-5.el7.x86_64
spice-server-0.12.4-5.el7.x86_64
spice-glib-0.22-1.el7.x86_64
spice-parent-15-11.el7.noarch
spice-protocol-0.12.6-2.el7.noarch
spice-gtk3-vala-0.22-1.el7.x86_64
spice-vdagent-0.14.0-7.el7.x86_64
spice-gtk-tools-0.22-1.el7.x86_64
spice-server-devel-0.12.4-5.el7.x86_64
spice-gtk-python-0.22-1.el7.x86_64
spice-gtk-devel-0.22-1.el7.x86_64
spice-gtk-0.22-1.el7.x86_64
spice-glib-devel-0.22-1.el7.x86_64
spice-gtk3-0.22-1.el7.x86_64


How reproducible:
always

Steps to Reproduce:
1. Prepare a health guest and start it.
# virsh list --all
 Id    Name                           State
----------------------------------------------------
 10    rhel66                         running
 11    rhel77                         running

2. Use virt-viewer open the guest in fullscreen
# virt-viewer rhel66 -f

3. Let mouse pointer hover above the menu at the top of the screen, then use keyboard shortcuts ctrl+[-] very frequently, that means repeat ctrl+- several times quickly.

Actual results:
1. The display of guest will turn to dark, and showing "Wait for display 1....".

2. After quit virt-viewer and try to connect guest again:
# virt-viewer rhel66
the screen is also in dark, but show message: Connected to graphic server

3. check the guest status:running

Expected results:
The guest can zoom in/out successfully, and showing normal.

Additional info:
1. I can reproduce this issue with both rhel6 and rhel7 guest on rhel7 host. The following is the qxl driver version of guest:
rhel66:
xorg-x11-drv-qxl-0.1.1-12.el6.x86_64
rhel77:
xorg-x11-drv-qxl-0.1.1-9.el7.x86_64

2. And as  Marc-Andre Lureau  said 
https://bugzilla.redhat.com/show_bug.cgi?id=989407#c10
i also changed vram from 64M to 128M, but also can hit the dark / disable display issue.

3. I will put the Xorg log and spice log later.

4. I use shutcuts ctrl+- can met this issue always, but ctrl++ just once

5. One more to say, before use shortcuts to zoom in/out guest screen, i use ssh to connect guest, after the display turn to dark, the connection to rhel6 guest can keep always, but connection to rhel7 guest always lost, sometimes will reconnected again after several minutes, sometimes lost connection thoroughly.

Comment 1 zhoujunqin 2014-08-07 06:21:57 UTC
Created attachment 924715 [details]
Xorg.0.log  for rhel6 guest

Comment 2 zhoujunqin 2014-08-07 06:22:53 UTC
Created attachment 924717 [details]
spice debug info for rhel6 guest

Comment 4 Marc-Andre Lureau 2014-08-07 10:13:13 UTC
(In reply to zhoujunqin from comment #1)
> Created attachment 924715 [details]
> Xorg.0.log  for rhel6 guest

This is the juicy part:

[  3391.485] (II) qxl(0): qxl_xf86crtc_resize: Placeholder resize 4000x2250
[  3391.485] resizing primary to 4000x2250
[  3391.485] resizing surface0 to 36000000
[  3391.485] qxl_dump_ring_stat: Cmd 3809/3809, Cur 1652/1652, Rel 166/166
[  3391.489] qxl_io_flush_release: collected 149
[  3391.489] qxl_dump_ring_stat: Cmd 3809/3809, Cur 1652/1652, Rel 171/171
[  3391.489] memory space from 0x7fe78dad1100 to 0x7fe793879000

And nothing after, black screen?

Comment 5 zhoujunqin 2014-08-07 10:26:41 UTC
(In reply to Marc-Andre Lureau from comment #4)
> (In reply to zhoujunqin from comment #1)
> > Created attachment 924715 [details]
> > Xorg.0.log  for rhel6 guest
> 
> This is the juicy part:
> 
> [  3391.485] (II) qxl(0): qxl_xf86crtc_resize: Placeholder resize 4000x2250
> [  3391.485] resizing primary to 4000x2250
> [  3391.485] resizing surface0 to 36000000
> [  3391.485] qxl_dump_ring_stat: Cmd 3809/3809, Cur 1652/1652, Rel 166/166
> [  3391.489] qxl_io_flush_release: collected 149
> [  3391.489] qxl_dump_ring_stat: Cmd 3809/3809, Cur 1652/1652, Rel 171/171
> [  3391.489] memory space from 0x7fe78dad1100 to 0x7fe793879000
> 
> And nothing after, black screen?

Yes, Marc-Andre Lureau, nothing after.
The Xorg.0.log content is before black screen i caught from guest.

Comment 6 Marc-Andre Lureau 2014-08-11 12:53:10 UTC
reverting patch from 1076728 in rhel6 also solves issue there

Comment 7 Marc-Andre Lureau 2014-08-11 18:04:32 UTC
sent patches to fix rhel7 guest:

http://lists.freedesktop.org/archives/spice-devel/2014-August/017182.html
http://lists.freedesktop.org/archives/spice-devel/2014-August/017183.html

rhel6 is fixed with xorg-x11-drv-qxl-0.1.1-1{1,3}.el6 (12 should never be released)

Comment 8 Fabiano Fidêncio 2014-10-17 10:01:52 UTC
*** Bug 1152593 has been marked as a duplicate of this bug. ***

Comment 12 Marc-Andre Lureau 2014-11-06 16:48:02 UTC
for qa: this bug was easily reproducible at the time of the fixes were provided, you just need to resize in very very large size (bigger than framebuffer) and you reach various issues solves here, kernel/qxl should NOT over allocate framebuffer or it will reach "qemu guest bug" and bad thing happen (black screen usually)! Unfortunately, it is something that #1076728 allows to do in rhel6 too..

so the patches for kernel are tracked in #1158233, and here is a fix for xorg qxl/kms to fallback to previous working configuration.

In short, #1076728 is wrong and must be reverted asap, #1158233 is required to avoid reaching qemu "guest bug", and this bug is for xorg qxl/kms driver.

Comment 19 zhoujunqin 2014-12-18 05:11:35 UTC
Created attachment 970383 [details]
qemu.log for guest kvm-rhel7.0-qcow2

Comment 20 Vaclav Ehrlich 2014-12-18 16:05:35 UTC
I've check it again with rhel7.1 guest/host/client and it seems to be ok.
Warning message appears when too big resolution is set.

Comment 23 errata-xmlrpc 2015-03-05 13:33:14 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-0578.html


Note You need to log in before you can comment on or make changes to this bug.