This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 989407 - ctrl-[+-0] zoom in/out/native keyboard shortcuts don't work in fullscreen (with mouse over the control bar)
ctrl-[+-0] zoom in/out/native keyboard shortcuts don't work in fullscreen (wi...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: virt-viewer (Show other bugs)
7.0
Unspecified Unspecified
medium Severity low
: rc
: ---
Assigned To: Default Assignee for SPICE Bugs
Virtualization Bugs
:
Depends On: 987549
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-29 04:41 EDT by hyao@redhat.com
Modified: 2015-03-05 08:37 EST (History)
13 users (show)

See Also:
Fixed In Version: virt-viewer-0.6.0-3.el7
Doc Type: Bug Fix
Doc Text:
When in fullscreen mode, if (and only if) the mouse pointer is hovering above the menu at the top of the screen, it is now possible to zoom in and out with keyboard shortcuts. Previously, this was not possible.
Story Points: ---
Clone Of: 987549
Environment:
Last Closed: 2015-03-05 08:37:42 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description hyao@redhat.com 2013-07-29 04:41:59 EDT
The bug is also reproduce on rhel7
# rpm -qa libvirt virt-viewer spice-*
spice-glib-0.20-2.el7.x86_64
spice-server-0.12.4-1.el7.x86_64
virt-viewer-0.5.6-1.el7.x86_64
spice-gtk-0.20-2.el7.x86_64
spice-gtk3-0.20-2.el7.x86_64
libvirt-1.1.0-2.el7.x86_64
spice-vdagent-0.14.0-3.el7.x86_64

Steps:
1. connect to a VM
2. make sure that zoom keyboard shortcuts work when windowed: with mouse cursor outside of guest area, press ctrl and minus keyboard shortcut (the guest is zoomed out); press ctrl and zero to get to normal size
3. put the guest in full screen
4. move the mouse pointer of top of "leave fullscreen"/.../exit control bar
5. press ctrl with minus again

Actual results:
nothing happens

Expected results:
guest should get zoomed out


+++ This bug was initially created as a clone of Bug #987549 +++

Description of problem:
ctrl-[+-0] zoom in/out/native keyboard shortcuts don't work in fullscreen (with mouse over the control bar)

Version-Release number of selected component (if applicable):
virt-viewer-0.5.6-2.el6.x86_64
spice-gtk-0.20-1.el6.x86_64

How reproducible:
always

Steps to Reproduce:
1. connect to a VM
2. make sure that zoom keyboard shortcuts work when windowed: with mouse cursor outside of guest area, press ctrl and minus keyboard shortcut (the guest is zoomed out); press ctrl and zero to get to normal size
3. put the guest in full screen
4. move the mouse pointer of top of "leave fullscreen"/.../exit control bar
5. press ctrl with minus again

Actual results:
nothing happens

Expected results:
guest should get zoomed out

Additional info:

--- Additional comment from Andrew Cathrow on 2013-07-24 08:37:19 EDT ---

Need to ensure that we have appropriate documentation on this as it's not immediately clear

--- Additional comment from David Jaša on 2013-07-24 08:57:46 EDT ---

(In reply to Andrew Cathrow from comment #1)
> Need to ensure that we have appropriate documentation on this as it's not
> immediately clear

The shortcuts are indicated right in the menu, so no other documentation is necessary and this is not a future feature.

--- Additional comment from Marc-Andre Lureau on 2013-07-25 06:01:23 EDT ---

David, there is a slight difference between the keyboard accelerator indicated in the gtk menu and "global" key binding (when the menu is not visibile).

I sent ctrl-0 patches to ML a few days ago, adding ctrl+ and ctrl- should be trivial now.
Comment 3 RHEL Product and Program Management 2014-03-24 01:51:06 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 7 zhoujunqin 2014-07-22 05:45:36 EDT
I can reproduce with packages:
virt-viewer-0.5.7-7.el7.x86_64

then try to verify with package but failed.
virt-viewer-0.6.0-1.el7.x86_64
spice-gtk3-0.22-1.el7.x86_64
spice-vdagent-0.14.0-7.el7.x86_64
spice-gtk-devel-0.22-1.el7.x86_64
spice-server-0.12.4-5.el7.x86_64
spice-glib-0.22-1.el7.x86_64
spice-gtk-tools-0.22-1.el7.x86_64
spice-glib-devel-0.22-1.el7.x86_64
spice-protocol-0.12.6-2.el7.noarch
spice-gtk-0.22-1.el7.x86_64
spice-gtk3-devel-0.22-1.el7.x86_64
spice-gtk3-vala-0.22-1.el7.x86_64
spice-gtk-python-0.22-1.el7.x86_64

steps as Comment 0 said.
After step4, shortkeys ctrl-[+-] zoom in/out still can not work in fullscreen.

I also found when click view--->Zoom, for Zoom In/Out there is no shortkeys showed as before.
Zoom In          Ctrl++
Zoom Out         Ctrl--
Zoom Normal      Ctrl+0

please help check, thanks.
Comment 8 Marc-Andre Lureau 2014-07-22 07:23:31 EDT
Sent fix https://www.redhat.com/archives/virt-tools-list/2014-July/msg00092.html
Comment 9 zhoujunqin 2014-08-06 06:54:22 EDT
Try to verify this bug issue with package: virt-viewer-0.6.0-3.el7.x86_64
other package version:
spice-gtk3-devel-0.22-1.el7.x86_64
spice-xpi-2.8-5.el7.x86_64
spice-server-0.12.4-5.el7.x86_64
spice-glib-0.22-1.el7.x86_64
spice-parent-15-11.el7.noarch
spice-protocol-0.12.6-2.el7.noarch
spice-gtk3-vala-0.22-1.el7.x86_64
spice-vdagent-0.14.0-7.el7.x86_64
spice-gtk-tools-0.22-1.el7.x86_64
spice-server-devel-0.12.4-5.el7.x86_64
spice-gtk-python-0.22-1.el7.x86_64
spice-gtk-devel-0.22-1.el7.x86_64
spice-gtk-0.22-1.el7.x86_64
spice-glib-devel-0.22-1.el7.x86_64
spice-gtk3-0.22-1.el7.x86_64

1.
And about Comment 7 issue,  afterclick view--->Zoom, for Zoom In/Out there are shortcuts showed as before.
Zoom In          Ctrl++
Zoom Out         Ctrl+-
Zoom Normal      Ctrl+0

2. 
steps as Comment 0 said.
After step4, shortcuts ctrl-[+-] zoom in/out works in fullscreen.

but i also found another thing, when i use shortcuts ctrl-[+-] very frequently, that means repeat ctrl++ or ctrl+- several times quickly, the fullscreen will turn to dark, and  showing "Wait for display 1....".
1)check the guest's status: running
# virsh dominfo rhel66
Id:             4
Name:           rhel66
UUID:           5899c555-37ee-c3b3-0941-923ce5db31f8
OS Type:        hvm
State:          running
CPU(s):         2
CPU time:       260.5s
Max memory:     2097152 KiB
Used memory:    2097152 KiB
Persistent:     yes
Autostart:      disable
Managed save:   no
Security model: selinux
Security DOI:   0
Security label: system_u:system_r:svirt_t:s0:c294,c580 (enforcing)

2) wait about 10 minutes, the guest always keep dark screen.
3) quit virt-viewer and try to connect guest again:
# virt-viewer rhel66
the screen is also in dark, but show message: Connected to graphic server
4) If restart the guest, showing is ok.

so Marc-Andre Lureau, please help check whether above is the expected result, thanks.
Comment 10 Marc-Andre Lureau 2014-08-06 08:33:40 EDT
(In reply to zhoujunqin from comment #9)
> but i also found another thing, when i use shortcuts ctrl-[+-] very
> frequently, that means repeat ctrl++ or ctrl+- several times quickly, the
> fullscreen will turn to dark, and  showing "Wait for display 1....".
> 1)check the guest's status: running
> [...] 
> 2) wait about 10 minutes, the guest always keep dark screen.
> 3) quit virt-viewer and try to connect guest again:
> # virt-viewer rhel66
> the screen is also in dark, but show message: Connected to graphic server

This is unrelated to this bug. It looks like a bug related to OOM on primary surface resize. What is the QXL driver version? Can you get the Xorg log once the VM is dark (via console/ssh)

I suggest to verify this bug and open another for the dark / disable display issue
Comment 11 zhoujunqin 2014-08-07 02:27:38 EDT
(In reply to Marc-Andre Lureau from comment #10)

> This is unrelated to this bug. It looks like a bug related to OOM on primary
> surface resize. What is the QXL driver version? Can you get the Xorg log
> once the VM is dark (via console/ssh)
> 
> I suggest to verify this bug and open another for the dark / disable display
> issue

Hi Marc-Andre Lureau,
thanks for your help and suggestion, i file another bug 1127552 to track Comment 9 issue, and move this bug status to VERIFIED.
Comment 13 errata-xmlrpc 2015-03-05 08:37:42 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-0295.html

Note You need to log in before you can comment on or make changes to this bug.