Bug 112757 - libc.so is an ASCII file in glibc-devel-2.3.3-2
libc.so is an ASCII file in glibc-devel-2.3.3-2
Status: CLOSED DUPLICATE of bug 112738
Product: Red Hat Raw Hide
Classification: Retired
Component: glibc (Show other bugs)
All Linux
medium Severity high
: ---
: ---
Assigned To: Jakub Jelinek
Brian Brock
Depends On:
  Show dependency treegraph
Reported: 2003-12-30 12:06 EST by Felipe Alfaro Solana
Modified: 2007-04-18 13:00 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-02-21 14:00:32 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Felipe Alfaro Solana 2003-12-30 12:06:54 EST
Description of problem: 
Starting with glibc-devel-2.3.3-2 the file /usr/lib/libc.so is a 
plain ASCII file with the following contents: 
/* GNU ld script 
   Use the shared library, but some functions are only in 
   the static library, so try that secondarily.  */ 
*** BUG in libc/scripts/output-format.sed *** elf32-i386,elf32-i386 
GROUP ( /lib/libc.so.6 /usr/lib/libc_nonshared.a ) 
This makes nearly impossible to compile anything while 
glibc-devel-2.3.3-2 is installed. Downgrading to glibc-devel-2.3.3-1 
fixes the problem. 
Version-Release number of selected component (if applicable): 
How reproducible: 
Steps to Reproduce: 
1. Upgrade to glibc-devel-2.3.3-2 
Actual results: 
/usr/lib/libc.so is a plain ASCII file, when in fact it should be a 
dynamic library. 
Expected results: 
/usr/lib/libc.so should be a dynamic library. 
Additional info:
Comment 1 Jakub Jelinek 2003-12-30 14:30:55 EST

*** This bug has been marked as a duplicate of 112738 ***
Comment 2 Red Hat Bugzilla 2006-02-21 14:00:32 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.