Bug 1127587 - [Networks] New/Edit> MTU Field Breaks the window layout, it doesn't look good.
Summary: [Networks] New/Edit> MTU Field Breaks the window layout, it doesn't look good.
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: oVirt
Classification: Retired
Component: ovirt-engine-webadmin
Version: 3.5
Hardware: x86_64
OS: Linux
high
medium
Target Milestone: ---
: 3.5.0
Assignee: Alona Kaplan
QA Contact: Martin Pavlik
URL:
Whiteboard: network
: 1127575 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-07 08:17 UTC by Michael Burman
Modified: 2016-02-10 19:37 UTC (History)
10 users (show)

Fixed In Version: ovirt-3.5.0_rc2
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-10-17 12:37:15 UTC
oVirt Team: Network


Attachments (Terms of Use)
edit logical network (123.37 KB, image/png)
2014-08-20 09:06 UTC, Eldan Hildesheim
no flags Details
arranged layout (47.11 KB, application/octet-stream)
2014-08-29 05:15 UTC, Eldan Hildesheim
no flags Details


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 32318 master MERGED webadmin: Fix layout of 'MTU' field in Network dialog Never
oVirt gerrit 32662 ovirt-engine-3.5 MERGED webadmin: Fix layout of 'MTU' field in Network dialog Never

Description Michael Burman 2014-08-07 08:17:11 UTC
Description of problem:
The MTU field in network window, Breaks the window layout. it doesn't look so good. Because in the new version added the custom field, it now breaking the layout. 

Version-Release number of selected component (if applicable):
 oVirt Engine Version: 3.5.0-0.0.master.20140804172041.git23b558e.el6 

How reproducible:
always

Steps to Reproduce:
1. Create  new network or edit exist one. 
2.
3.

Actual results:
MTU field Breaking the layout with the additional custom field.

Expected results:
Should look straight. 

Additional info:

Comment 1 Alona Kaplan 2014-08-12 11:33:33 UTC
*** Bug 1127575 has been marked as a duplicate of this bug. ***

Comment 2 Lior Vernia 2014-08-12 11:38:24 UTC
Since Bug 1127575 was closed, adding UserExperience here...

Comment 3 Einav Cohen 2014-08-18 18:11:56 UTC
Eldan - can you please help out here? more details in the duplicate bug 1127587 - just sitting with the relevant network developer and closing this in a short loop makes sense here. thanks.

Comment 4 Einav Cohen 2014-08-18 19:26:08 UTC
(In reply to Einav Cohen from comment #3)
> Eldan - can you please help out here? more details in the duplicate bug
> 1127587 - just sitting with the relevant network developer and closing this
> in a short loop makes sense here. thanks.

correction: duplicate bug for reference is Bug 1127575. thanks.

Comment 5 Einav Cohen 2014-08-19 15:50:25 UTC
Eldan: Clarification:

Take a look at attachment 924778 [details]: You can see that the entire "Network Parameters" section is looking quite messy. 

In particular, it seems that the 'MTU' field (http://i.imgur.com/sMpA6IC.png) is root cause for the messy look & feel (i.e. the "Enable VLAN Tagging", "VM Network" and "Network Label" fields are pretty-much OK, but the "MTU" field (with the two radio buttons, one of them containing a text-box, etc.) seems to mess up the entire layout. 

So we need to tweak the layout for this section so that it will look better; I guess that it can involve changing only the "MTU" field layout, or maybe tweaking all of the fields in the "Network Parameters" section so that it will look reasonable - not sure, I am leaving this up to you, the UXD expert :)

I suggest working with Alona (BZ assignee) in a short loop to fix this issue (again, I assume it will only require very few tweaks) - it would probably be more efficient than going back and forth with Liz and I on the solution.

can you please do that?

thanks.

Comment 6 Eldan Hildesheim 2014-08-20 09:06:38 UTC
Created attachment 928723 [details]
edit logical network

Comment 7 Einav Cohen 2014-08-20 13:19:45 UTC
(In reply to Eldan Hildesheim from comment #6)
> Created attachment 928723 [details]
> edit logical network

Thanks, Eldan; I am missing in your suggestion the text-box for entering a Custom MTU (see http://i.imgur.com/sMpA6IC.png - note the text-box within the "Custom" radio-button) - where will it be in your design?

Comment 8 Eldan Hildesheim 2014-08-29 05:15:00 UTC
Created attachment 932549 [details]
arranged layout

Comment 9 Martin Pavlik 2014-09-11 11:08:54 UTC
verified on  Red Hat Enterprise Virtualization Manager Version: 3.5.0-0.11.beta.el6ev 

the reason for the new MTU radiobutton is that defualt MTU is now configurable for the engine

engine-config -s "DefaultMtu=1500"

Comment 10 Sandro Bonazzola 2014-10-17 12:37:15 UTC
oVirt 3.5 has been released and should include the fix for this issue.


Note You need to log in before you can comment on or make changes to this bug.