Bug 1127694 - Miss UEFI info when install RHEVH to UEFI machine
Summary: Miss UEFI info when install RHEVH to UEFI machine
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-node
Version: 3.5.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 3.5.0
Assignee: Fabian Deutsch
QA Contact: Virtualization Bugs
URL:
Whiteboard: node
: 1127566 (view as bug list)
Depends On: rebase-ovirt-node-3.1
Blocks: rhevh-7.0
TreeView+ depends on / blocked
 
Reported: 2014-08-07 11:07 UTC by cshao
Modified: 2016-02-10 20:05 UTC (History)
14 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-02-11 21:01:10 UTC
oVirt Team: Node


Attachments (Terms of Use)
rhevh6 vs rhevh7 (69.85 KB, image/png)
2014-08-07 11:07 UTC, cshao
no flags Details
dmesg (506.22 KB, text/plain)
2014-08-08 07:45 UTC, cshao
no flags Details
lsmod (3.40 KB, text/plain)
2014-08-08 07:45 UTC, cshao
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2015:0160 normal SHIPPED_LIVE ovirt-node bug fix and enhancement update 2015-02-12 01:34:52 UTC
oVirt gerrit 31243 master MERGED recipe: Add EFI related pkgs to EL7 Never
Red Hat Bugzilla 1127566 None None None Never

Internal Links: 1127566

Description cshao 2014-08-07 11:07:06 UTC
Created attachment 924885 [details]
rhevh6 vs rhevh7

Description of problem:
Miss UEFI info when install RHEVH to UEFI machine.
e.g.(Info: Machine is booted in EFI mode)

Version-Release number of selected component (if applicable):
ovirt-node-3.1.0-0.7.20140806gitef5c5cb.el7.noarch
rhev-hypervisor7-7.0-20140806.1.iso

How reproducible:
100%

Steps to Reproduce:
1. Install RHEV-H to UEFI machine.
2. Focus on the first installation page.
3. Please see attachment for more details.

Actual results:
Miss UEFI info when install RHEVH to UEFI machine.

Expected results:
Pop-up uefi info.

Additional info:
def is_efi():
"""If the system is booted in (U)EFI mode
"""
return os.path.exists("/sys/firmware/efi")

Comment 1 Fabian Deutsch 2014-08-07 11:44:38 UTC
Chen, could you please provide the output of
$ dmesg
$ lsmod
on the rhl7 host

And are you sure that you booted in EFI mode and not the compatability mode?

Comment 2 cshao 2014-08-08 06:05:42 UTC
(In reply to Fabian Deutsch from comment #1)
> Chen, could you please provide the output of
> $ dmesg
> $ lsmod
> on the rhl7 host
> 
Please see log(dmesg&lsmod) in attachment.

> And are you sure that you booted in EFI mode and not the compatability mode?
Yes, I can sure that booted in EFI mode, please focus on pic "rhevh6 vs rhevh7", there are from the same machine and same EFI mode.
Thanks!

Comment 3 cshao 2014-08-08 07:45:20 UTC
Created attachment 925108 [details]
dmesg

Comment 4 cshao 2014-08-08 07:45:48 UTC
Created attachment 925109 [details]
lsmod

Comment 5 Fabian Deutsch 2014-08-11 14:41:18 UTC
*** Bug 1127566 has been marked as a duplicate of this bug. ***

Comment 6 Ying Cui 2014-10-16 08:48:26 UTC
Need devel_ack and pm_ack this bug.

Comment 7 Ying Cui 2014-10-16 08:49:18 UTC
(In reply to Ying Cui from comment #6)
> Need devel_ack and pm_ack this bug.

Because the bug is ON_QA, we need 3 ack+

Comment 8 cshao 2014-10-17 02:19:58 UTC
Test version:
rhev-hypervisor7-7.0-20141006.0.el7ev.noarch
ovirt-node-3.1.0-0.20.20141006gitc421e04.el7.noarch

Test Steps:
1. Install RHEV-H to UEFI machine.
2. Focus on the first installation page.

Test Result:
Pop-up uefi info.

So the bug is fixed, I will verify this bug after got 3 ack+.

Thanks!

Comment 10 cshao 2014-12-18 13:19:12 UTC
Test version:
rhev-hypervisor7-7.0-20141212.0.iso
ovirt-node-3.1.0-0.34.20141210git0c9c493.el7.noarch

Test steps:
1. Install RHEV-H to UEFI machine.
2. Focus on the first installation page.

Test Result:
Pop-up uefi info.

So the bug is fixed with above build now, change bug status to VERIFIED.

Comment 12 errata-xmlrpc 2015-02-11 21:01:10 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2015-0160.html


Note You need to log in before you can comment on or make changes to this bug.