Bug 1127863 - [RFE] Need to make sure that during deployment, RHEL OSP Installer pushes out ceph.conf and keyring to Ceph Storage Cluster Nodes, Controller Nodes and Compute Nodes
Summary: [RFE] Need to make sure that during deployment, RHEL OSP Installer pushes out...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-foreman-installer
Version: 5.0 (RHEL 7)
Hardware: x86_64
OS: Linux
high
high
Target Milestone: z1
: Installer
Assignee: Crag Wolfe
QA Contact: Yogev Rabl
URL:
Whiteboard: MVP
Depends On:
Blocks: 1108193
TreeView+ depends on / blocked
 
Reported: 2014-08-07 17:34 UTC by arkady kanevsky
Modified: 2016-04-26 15:31 UTC (History)
17 users (show)

Fixed In Version: openstack-foreman-installer-2.0.23-1.el6ost
Doc Type: Enhancement
Doc Text:
Clone Of: 1127862
Environment:
Last Closed: 2014-10-01 13:26:18 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:1350 normal SHIPPED_LIVE Red Hat Enterprise Linux OpenStack Platform Bug Fix Advisory 2014-10-01 17:22:34 UTC

Description arkady kanevsky 2014-08-07 17:34:35 UTC
Description of problem:
Need to make sure that during deployment, RHEL OSP Installer pushes out ceph.conf and keyring to Ceph Storage Cluster Nodes, Controller Nodes and Compute Nodes

Version-Release number of selected component (if applicable):
N/A

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 3 Mike Burns 2014-08-07 22:48:07 UTC
This assumes that the correct ceph.conf and the keyring exist on the foreman host when the deployment is run.

Comment 4 Crag Wolfe 2014-09-04 01:55:24 UTC
Patch posted: https://github.com/redhat-openstack/astapor/pull/358

Comment 5 Jason Guiditta 2014-09-08 21:04:47 UTC
Merged

Comment 8 Yogev Rabl 2014-09-22 10:09:36 UTC
verified in version ruby193-rubygem-staypuft-0.3.5-1.el6ost.noarch

Comment 13 errata-xmlrpc 2014-10-01 13:26:18 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1350.html


Note You need to log in before you can comment on or make changes to this bug.