Bug 1127862 - [RFE] Need to make sure that Controller and Compute Nodes deploy with Ceph Client libraries and packages
Summary: [RFE] Need to make sure that Controller and Compute Nodes deploy with Ceph Cl...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-foreman-installer
Version: 5.0 (RHEL 7)
Hardware: x86_64
OS: Linux
high
high
Target Milestone: z1
: Installer
Assignee: Crag Wolfe
QA Contact: Yogev Rabl
URL: https://trello.com/c/dLT8Wbs6
Whiteboard: MVP
Depends On:
Blocks: 1108193
TreeView+ depends on / blocked
 
Reported: 2014-08-07 17:32 UTC by arkady kanevsky
Modified: 2016-04-26 22:12 UTC (History)
14 users (show)

Fixed In Version: openstack-foreman-installer-2.0.19-1.el6ost
Doc Type: Enhancement
Doc Text:
A feature has been added to the RHEL OpenStack Platform installer which installs Ceph-related packages automatically, when Rados Block Device (RBD) is enabled on controller or compute nodes. This is required so that, when using RBD as a back end for Block Storage or Image, the Ceph-related packages are installed. Now, the Ceph-packages no longer need to be manually installed when using RBD as a Block Storage or Image back end.
Clone Of: 1127859
: 1127863 (view as bug list)
Environment:
Last Closed: 2014-10-01 13:26:14 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:1350 normal SHIPPED_LIVE Red Hat Enterprise Linux OpenStack Platform Bug Fix Advisory 2014-10-01 17:22:34 UTC

Description arkady kanevsky 2014-08-07 17:32:16 UTC
Description of problem:
Need to make sure that Controller and Compute Nodes deploy with Ceph Client libraries and packages

Version-Release number of selected component (if applicable):
N/A

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 3 Crag Wolfe 2014-08-07 19:17:54 UTC
Patch posted: https://github.com/redhat-openstack/astapor/pull/340

Comment 6 Yogev Rabl 2014-09-18 12:43:50 UTC
verified: 
# rpm -qa | grep ceph
ceph-common-0.80.5-1.el7ost.x86_64
python-ceph-0.80.5-1.el7ost.x86_64

on version: ruby193-rubygem-staypuft-0.3.5-1.el6ost.noarch

Comment 8 errata-xmlrpc 2014-10-01 13:26:14 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1350.html


Note You need to log in before you can comment on or make changes to this bug.