Bug 112793 - Per-profile device selection doesn't work
Per-profile device selection doesn't work
Status: CLOSED DUPLICATE of bug 85651
Product: Fedora
Classification: Fedora
Component: redhat-config-network (Show other bugs)
1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
:
: 122856 (view as bug list)
Depends On:
Blocks: rcn-profiling
  Show dependency treegraph
 
Reported: 2003-12-31 21:59 EST by Reuben Thomas
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-16 09:44:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Reuben Thomas 2003-12-31 21:59:21 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; Linux i686; U) Opera 7.23  [en]

Description of problem:
Whenever I select or deselect a device in one profile, it is selected 
or deselected in all profiles. This means that profiles are pretty 
much useless (unless I set up the links in 
/etc/sysconfig/networking/profiles manually).

This seemed such a major bug, I double-checked by moving aside my 
/etc/sysconfig/networking directory and restarting (this caused a 
crash, so I did mkdir for that directory, which then allowed me to 
recreate my config from scratch but only confirmed the bug described 
above).

Version-Release number of selected component (if applicable):
1.3.10-1

How reproducible:
Always

Steps to Reproduce:
1. Tick or untick a device in one profile.
2. Save the settings.
3. Switch to another profile. The change will have also been made to 
this profile. Looking at the hard links in 
/etc/sysconfig/networking/profiles confirms that this is really 
happening.
    

Actual Results:  The activation/deactivation of devices in profiles 
should be independent (especially when the devices are network 
logical copies of each other, which the manual says should not be 
able to be activated in the same profile!)

Expected Results:  The settings in different profiles should be 
different.

Additional info:

This tool seems badly broken which made me wonder if it's something 
that I'm doing, but since removing the whole config and restarting 
gave the same results I'm reporting as a bug. As an example of 
another problem, if I copy a device (to get a logical network copy), 
the corresponding file isn't created in 
/etc/sysconfig/network-scripts, so I then can't activate the device..
.
Comment 1 Mike Frisch 2004-04-02 14:27:19 EST
I found that I must create a default profile for each case (ie. one
home, one office).  Using the default profile for "office", for
example, did not work and I saw the same thing you did.

IMO, the UI behaviour is not quite as expected, in my opinion.
Comment 2 Miloslav Trmac 2004-05-10 09:59:24 EDT
*** Bug 122856 has been marked as a duplicate of this bug. ***
Comment 3 Harald Hoyer 2005-09-16 09:44:51 EDT

*** This bug has been marked as a duplicate of 85651 ***

Note You need to log in before you can comment on or make changes to this bug.