Bug 1127961 - tox tracebacks in swiftclient
Summary: tox tracebacks in swiftclient
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: python-tox
Version: 20
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Matthias Runge
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-08 02:03 UTC by Pete Zaitcev
Modified: 2014-08-27 01:34 UTC (History)
2 users (show)

Fixed In Version: python-tox-1.7.1-3.fc20
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-27 01:34:10 UTC


Attachments (Terms of Use)

Description Pete Zaitcev 2014-08-08 02:03:14 UTC
Description of problem:

I ran yum update on my F20 and now nothing works (well, pep8 works).

Traceback with
 tox.ConfigError: ConfigError: substitution key 'posargs' not found

Version-Release number of selected component (if applicable):

python-tox-1.7.1-2.fc20.noarch

How reproducible:

Synchronous

Steps to Reproduce:
1. git clone git://github.com/openstack/python-swiftclient.git
2. tox -e py27

Actual results:

Traceback with posargs

Expected results:

No traceback

Additional info:

https://bitbucket.org/hpk42/tox/issue/150/posargs-configerror

Could we carry the patch for 1.7 until 1.7.2 ships, please?

Comment 1 Matthias Runge 2014-08-13 19:47:19 UTC
*** Bug 1128562 has been marked as a duplicate of this bug. ***

Comment 2 Fedora Update System 2014-08-13 20:14:21 UTC
python-tox-1.7.1-3.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/python-tox-1.7.1-3.fc20

Comment 3 Fedora Update System 2014-08-16 00:28:14 UTC
Package python-tox-1.7.1-3.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing python-tox-1.7.1-3.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-9442/python-tox-1.7.1-3.fc20
then log in and leave karma (feedback).

Comment 4 Fedora Update System 2014-08-27 01:34:10 UTC
python-tox-1.7.1-3.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.