Bug 1128562 - tox.ConfigError: ConfigError: substitution key 'posargs' not found
Summary: tox.ConfigError: ConfigError: substitution key 'posargs' not found
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: python-tox
Version: 20
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
Assignee: Matthias Runge
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-11 05:36 UTC by Mark McLoughlin
Modified: 2014-08-27 01:34 UTC (History)
1 user (show)

Fixed In Version: python-tox-1.7.1-3.fc20
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-13 19:47:19 UTC


Attachments (Terms of Use)

Description Mark McLoughlin 2014-08-11 05:36:56 UTC
Running OpenStack's oslo.messaging tests with python-tox 1.7.1-2.fc20 on Fedora 20 gives me:

  tox.ConfigError: ConfigError: substitution key 'posargs' not found

Apparently this is because the handling of '{posargs}' breaks:

  commands = python setup.py testr --slowest --testr-args='{posargs}'

The issue is tracked by OpenStack here:

  https://bugs.launchpad.net/openstack-ci/+bug/1274135

with their recommendation being to downgrade to 1.6.1

Apparently the issue is now fixed by this commit in tox 1.7.2:

  https://bitbucket.org/hpk42/tox/pull-request/85/fix-command-expansion-and-parsing/diff

Comment 1 Mark McLoughlin 2014-08-11 05:47:08 UTC
To workaround, I dropped back to 1.6.1:

  $ yum remove python-tox
  $ yum upgrade https://kojipkgs.fedoraproject.org//packages/python-tox/1.6.1/2.fc21/noarch/python-tox-1.6.1-2.fc21.noarch.rpm

and added this exclude to my repo config:

  # For https://bugzilla.redhat.com/1128562
  exclude=python-tox

Comment 2 Matthias Runge 2014-08-13 19:47:19 UTC

*** This bug has been marked as a duplicate of bug 1127961 ***

Comment 3 Fedora Update System 2014-08-13 20:14:22 UTC
python-tox-1.7.1-3.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/python-tox-1.7.1-3.fc20

Comment 4 Fedora Update System 2014-08-27 01:34:11 UTC
python-tox-1.7.1-3.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.