Bug 1128137 - Showing a blue screen after installation when tboot is enabled
Summary: Showing a blue screen after installation when tboot is enabled
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: grub
Version: 6.6
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: rc
: ---
Assignee: Jan Grulich
QA Contact: Release Test Team
URL:
Whiteboard:
Depends On:
Blocks: 1083985
TreeView+ depends on / blocked
 
Reported: 2014-08-08 11:31 UTC by sumathi
Modified: 2014-10-14 06:44 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: Use tboot together with grub containing fix for bug 1048681. Consequence: The screen is blue in tboot and in KVM guest stays blue on tty. Fix: The fix adds additional condition for EFI platforms when initializing graphics. Result: The output is normal and not blue.
Clone Of:
Environment:
Last Closed: 2014-10-14 06:44:08 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:1476 normal SHIPPED_LIVE grub bug fix update 2014-10-14 01:28:40 UTC

Description sumathi 2014-08-08 11:31:56 UTC
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 2 Pavel Holica 2014-08-12 09:24:08 UTC
Description of problem:
When tboot is used together with grub containing fix for bug 1048681, the screen is blue in tboot and in KVM guest stays blue on tty.

Version-Release number of selected component (if applicable):
RHEL-6.6-20140731.1 x86_64 Client
grub-0.97-89.el6
tboot-1.8.1-1.el6

How reproducible:
always

Steps to Reproduce:
1. Start installation on x86_64 (any variant)
2. Proceed with defaults to package selection
3. At package selection select minimal and "modify package selection now"
4. Select base and optional packages
5. Find tboot and select it
6. After installation finishes, reboot

Actual results:
After grub there is just blue screen and tboot output is not visible, when switching ttys, screen stays blue.

Expected results:
tboot output is visible, no bluescreen, ttys are usable.

Additional info:
Switching component to grub. I've tried RHEL-6.5 x86_64 Client GA and then updated tboot, rebooted and output was ok. Then I've tried updating grub, ran grub-install /dev/sda, rebooted and screen was blue.

Comment 3 Pavel Holica 2014-08-12 09:30:37 UTC
Also one more note, this was BIOS installation and tboot is afaik not compatible with UEFI.

Comment 4 Jan Grulich 2014-08-12 13:23:23 UTC
Should be fixed in grub-0.97-90.el6.

Comment 6 Pavel Holica 2014-08-14 07:38:08 UTC
Verified fix on RHEL-6.6-20140812.1 x86_64 Client with grub-0.97-90.el6.x86_64 and tboot-1.8.1-1.el6.x86_64.

Comment 7 errata-xmlrpc 2014-10-14 06:44:08 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1476.html


Note You need to log in before you can comment on or make changes to this bug.