Bug 1128238 - Activation Key tab hidden if content view not selected in host group definition
Summary: Activation Key tab hidden if content view not selected in host group definition
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Provisioning
Version: 6.0.4
Hardware: Unspecified
OS: Unspecified
unspecified
medium vote
Target Milestone: Unspecified
Assignee: Christine Fouant
QA Contact: Kedar Bidarkar
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-08 16:28 UTC by Nick Strugnell
Modified: 2019-04-01 20:26 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-27 08:43:26 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1500 normal SHIPPED_LIVE Red Hat Satellite 6.2 Base Libraries 2016-07-27 12:24:38 UTC

Description Nick Strugnell 2014-08-08 16:28:49 UTC
Description of problem:
When defining a host group, the option is provided to select a Content View (CV). If not CV is selected, then the Default Organisation View (i.e. the head of the Library) is used. However, in this case the Activation Key tab is hidden, and no activation key can be entered for the host group.

This means that it is currently not possible to create hosts that use the Default Organisation View in order to ensure they are always up to date with the latest updates.

Version-Release number of selected component (if applicable):
6.0.4

How reproducible:
Always

Steps to Reproduce:
1. Create a new host group
2. Leave the Content View select box blank
3.

Actual results:
The Activation Key tab is hidden and no Activation Key can be entered


Expected results:
The Activation Key tab should be visible.

Additional info:

Comment 1 RHEL Product and Program Management 2014-08-08 16:34:02 UTC
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.

Comment 3 Christine Fouant 2015-07-23 16:09:05 UTC
Tested with 6.1 Snap 14 - Default Organization View is a content view option for a Host Group.

Comment 4 Justin Sherrill 2016-03-28 06:28:43 UTC
Activation keys now show up when this environment is the default content view.  

In the process i discovered 
https://bugzilla.redhat.com/show_bug.cgi?id=1321511

Comment 7 errata-xmlrpc 2016-07-27 08:43:26 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1500


Note You need to log in before you can comment on or make changes to this bug.