Bug 1128443 - Edit running VM vcpu setting applied immediately, though chosen to be applied later.
Summary: Edit running VM vcpu setting applied immediately, though chosen to be applied...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: oVirt
Classification: Retired
Component: ovirt-engine-core
Version: unspecified
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 3.5.0
Assignee: Omer Frenkel
QA Contact: Lukas Svaty
URL:
Whiteboard: virt
: 1128442 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-10 13:32 UTC by Ilanit Stein
Modified: 2016-02-10 19:49 UTC (History)
9 users (show)

Fixed In Version: ovirt-3.5.0_rc2
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-10-17 12:41:22 UTC
oVirt Team: Virt


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 32286 master MERGED core: handle hot-set and update running vm Never
oVirt gerrit 32399 ovirt-engine-3.5 MERGED core: handle hot-set and update running vm Never

Description Ilanit Stein 2014-08-10 13:32:32 UTC
Description of problem:
Edit running VM with parameters, that will be applied on next run, for example memory, and also change vcpu socket number, and choose to apply later.
VM General tab, at the bottom, vm will show the new value, that shouldn't have yet applied, unlike other "Next boot" parameters, like memory, that still show previous value, in the general tab. 
Also Read VM via REST, also show the new socket number.

Version-Release number of selected component (if applicable):
ovirt-engine 3.5-rc1

How reproducible:
100%

Comment 1 Omer Frenkel 2014-08-31 14:01:38 UTC
the "apply later" only refer to hot plug where possible, so currently its only cpu.
if you change name/description/etc.. it will apply immediately, always. (like in previous versions)
if you change memory/boot order/etc.. it will be applied when vm is down (in previous versions, it was blocked)
currently, only for cpu user can choose if to apply immediately (hot-plug) or on next-run.

if i understand correctly, this is not a bug, right?

Comment 2 Ilanit Stein 2014-09-01 11:18:22 UTC
This bug might be related to bug 1128442

Comment 3 Omer Frenkel 2014-09-01 11:29:29 UTC
Ok i did not understand correctly the description, its indeed another effect of the problem in bug 1128442
the problem is that the number of sockets is marked in the backend as always editable, and therefor the config is saved immediately, and the dialog doesn't open for it.

Comment 4 Omer Frenkel 2014-09-02 06:55:43 UTC
*** Bug 1128442 has been marked as a duplicate of this bug. ***

Comment 5 Lukas Svaty 2014-09-16 13:15:56 UTC
verified in vt3

Comment 6 Sandro Bonazzola 2014-10-17 12:41:22 UTC
oVirt 3.5 has been released and should include the fix for this issue.


Note You need to log in before you can comment on or make changes to this bug.